Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

"Failed to open document. You don't have access to this document"

Hi there,

our user from abroad are facing a problem with opening our application via the desktop client.

If the use "Open in Server" everything is ok. Unfortunately our users shall be able to use the application offline so they open it directly from a network drive or save the application to their local disc an open this copy.

Both ways do not work for them - but only for international users. The users here in our main office do not have any problems.

Even using a command line prompt to open the application via server does not work. The only way for our international users so far is to use the "open in server".

This is the error message the users see:
error.jpg

I am not sure if this has someting to do with our section access but that was what I found looking for this error message. In this case we only use section access to grant users acces to the application, we do not limit the data with section access in any way.

Could it be a problem with section access? Or might there be something wrong with network connection, ports, firewalls or whatever? Has anyone ever had a problem like this?


Thanks for your help and best regards,

Chris

1 Solution

Accepted Solutions
Not applicable

Re: "Failed to open document. You don't have access to this document"

Hi there,

I could solve the problem:

We start our application by using a command line. To provide new users a valid license on their initial start we open a small (empty) file on the server an try to reload it using this command:

"C:\Program Files\QlikView\Qv.exe" /r "qvp://ServerName/Buffer.qvw"

Since a reload is not possible when opening in server Qv is closed after opening the file and the script goes on opening the application (the license is now stored in the settings.ini on the C-drive as a license has been leased by opening the buffer-file on server.

Unfortunately the Buffer-file opened on the server is a copy of the application itself. Every object in the Buffer-file has been deleted as well as the complete script. However, I did not execute the script after that so there was still a section access valid for the Buffer-file. The last script update of this file has been executed some 3 months ago which means that new users have access to the main application but not to the Buffer-file.

After executing a reload in the Buffer-file everything was ok and it works fine for our new users as well.

Thanks for your help and best regards,

Chris

12 Replies
morris70
Valued Contributor

Re: "Failed to open document. You don't have access to this document"

I am guessing that it has something to do with the section access. I would try checking the SA table to make sure these users are present in the table with the correct credentials. I am not quite sure why it would work on "open in server" but not in the local copy.  Also if you have a user that you trust and can use for a test, try setting that user to admin in the SA table and then test. Remember to change this back, this should not really matter in your case as you do not do any data limitation but it is always good practice to have the right permission level in place even if it doe not make a difference.

Not applicable

Re: "Failed to open document. You don't have access to this document"

I guess it has implemented the section access in the application.

Not applicable

Re: "Failed to open document. You don't have access to this document"

Nils, thanks for your reply.

The user names are correct in the SA table. I removed a colleague sitting next to me from the SA table. He can't open the application and sees this error message:

"Access denied to this QlikView document"

However, this is different from the message our users from abroad see.

I went trough the document settings of our application but I can't see anything that might be wrong there.

Best regards,

Chris

sanketkhunte
Contributor II

Re: "Failed to open document. You don't have access to this document"

Definatly : Section Access with Windonws NT have been implemented to Qlikview file to which user is trying to open and User do not have access for the same.

For resovling this problem - Developer/Engineer  must need to create USERID in section access table for the same user then only he/she can able to access from same environment.

Thank you.

Sanket 

morris70
Valued Contributor

Re: "Failed to open document. You don't have access to this document"

I noticed now that they are using "Personal Edition". They should lease a license from the server first (open in server) then close the document and the try to open it locally.

Not applicable

Re: "Failed to open document. You don't have access to this document"

Hi Chris,

From the error message screenshot which you have posted, I can see that the users are trying to open the application through Qlikview personal edition.

In Qv personal edition you won't be able to open the documents created by other users, this might be the reason for users not able to open the document.

A remedy to this is, you can ask users to lease the license from server once by using "Open in server" (only if it suits your licensing policies) and then they will be able to open the files.

Hope this helps!

Not applicable

Re: "Failed to open document. You don't have access to this document"

Hi Shyamal, hi Nils,

you are right, it states "Personal Edition". We start our application via command line and the screenshot was taken during the initial start right after the installation of the desktop client.

The users only had a Personal Edition and tried to get their license by opening a file on the server from command line. This is usually no problem, but in this case the users are not able to access this file. That's why it still states "Personal Edition".

If a user can't access a file because he/she has no license there is another error message (at first the user is asked if he/she wants to use the 5 or 4 attempts to open a file created with another desktop client in PE. If the user does not want to do so QV only states "Failed to open document".

I already asked the colleagues to first of all open the application in server which was ok. A valid license was existing after that but the user were not able to open a local copy of the application (the error message from the subject line came up).

Thanks and best regards,

Chris

Not applicable

Re: "Failed to open document. You don't have access to this document"

See if http://community.qlik.com/message/277887 can be of some help.

Not applicable

Re: "Failed to open document. You don't have access to this document"

Thanks for this link. I came across it yesterday a unticked "Strict Exclusion" but it didn't help.

For testing i just created a new file wihtout any security (no section access) but the user can't open this file either and gets the same error message.

It looks like it does not have to do with section access.

Best regards,

Chris