Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

what if one of the service is not running?

Hi Experts

I did office 2007 installation on DEV server and server req reboot of the server, so I did it

Now,  it shows that one of the service is not running, in that case what should I do? Do I need to restart it again?

If we go to QEMC-->Status-->Services-->QVS@DEVserver, it shows the message as "No valid document directory set" and its status as off duty.

Please help me

22 Replies
Employee
Employee

what if one of the service is not running?

Your document root folder is probably invalid. If you go to System > Setup > QlikView Servers > QVS@DEVServer > Folders, what is the Root Folder setting?

If you cannot access these settings, you can see the setting in the Settings.ini file under C:\ProgramData\QlikTech\QlikViewServer.

Not applicable

what if one of the service is not running?

On  System > Setup > QlikView Servers > QVS@DEVServer > Folders and  C:\ProgramData\QlikTech\QlikViewServer--> 'setting' (configuration file), found same address.

Everytime after maintainace break, I used to get this 'No Server' error.

Is there any other solution ?

Not applicable

what if one of the service is not running?

In the C:\ProgramData\QlikTech\QlikViewServer--> 'setting', in this file Document Directory = ' root folder address'.

MVP
MVP

Re: what if one of the service is not running?

Hi Avantika,

In addition to what Stefan says, did you check the Windows Services console (start button, run, services.msc) that all QlikView services are up and running? There are some cases when the services don't start after a reboot, and you need to do it manually.

Hope that helps.

Miguel

Not applicable

what if one of the service is not running?

Hi Mighuel

Yes, upto my knowledge services were running but for the next time I'll make sure that I'll check services first.

This happens everytime that's why a reason to worry for me.

Br

Avantika

Not applicable

what if one of the service is not running?

Hi Miguel

Again I faced the same issue, the Service QVS @ dev is always shows as a "off duty" when we restart the serivces.

Please find the attached screen shot, what's wrong with this service, can you tell me ?Error1.JPG

chauhans85
Esteemed Contributor

what if one of the service is not running?

have you applied licence o server if yes

then apply again and restart qlikview server

hope this helps

Not applicable

what if one of the service is not running?

Hi a_thodge,

This used to happen to us after every server reboot until we disabled the windows IIS Admin Service. This can be disabled by Start, Run, Services.msc. Look for the IIS Admin Service and disable it. The QVS service worked after that.

Hope it helps.

Regards GJ.

MVP
MVP

Re: what if one of the service is not running?

Hi,


The "Off Duty" message usually appears when there are two servers in the same network with the same license number and when this license number does not allow clustering or the number of nodes allowed has been exceeded. Make sure there is no more than one server in your network, or that all servers have a different license number.

Regards.

Miguel

Community Browser