Qlik Community

QlikView Documents

Documents for QlikView related information.

Improving Image Quality Export using Clipboard Zoom

lubicz99
Valued Contributor

Improving Image Quality Export using Clipboard Zoom

Greetings,

For the longest time, I have been trying to improve the quality of an exported image out of Qlikview.  Sometimes my end users want to just copy an image to the clipboard and paste it into an e-mail or a Word document.  By default these images export with less than desirable quality.  In particular, I use Nprinting and the image quality was so poor, we almost could not use the application.

Well, sometime a blind squirrel finds a nut or in my case the lottery ticket that wins you a millions dollars.

There is a setting in the User Preferences in Qlikview called Clipboard Zoom.  See attached Word Document.  By default, this setting is at 100 % in order to minimize the file size of the output.  This also leads to less than desirable quality.  I included an image from the sample surgical dashboard at 100 %.  I then change the setting to 400 % and copied the image to the clipboard and pasted the same image to the Word document   The results are astounding.  If you view the 400 % file, you can enlarge it and still get good quality.  The only sacrifice is that the file size of the image is substantially bigger.  I will gladly trade file size for image quality.

Try zooming on the images in the Word document.  It is night and day difference.

Now, here is the tricky part.  The setting is a User Preference.   So, even if I change it on my developers machine, I need to make sure the setting is changed on my end users desktop client.   If you are using Nprinting, you can specify the user name and password when you are connecting to the source data.

As a general rule, you should probably size your objects in Qlikview about the same size that you would like to appear in your external document after you export it.  This will minimize possible distortion as you scale it further.

I hope this post is helpful for you today.

Mike Czerwonky

BI Developer

Comments
mwoolf
Honored Contributor II

Mike,

I've been looking for this.

I find that just changing to 110% makes a visible difference in the image quality.

Nice find and thanks for sharing.

Now... how to push this to all accesspoint users' settings.ini files....

lubicz99
Valued Contributor

I did think about that too.  I spent quite a bit of time in QMC looking for a similar setting without any luck.  That sure seems like a good question for the support team.

Anybody out there on the support team have an answer on how to globally change User preference settings?

I stumbled on this fix accidentally.  I was trying to figure out why my charts were exporting without borders. On the same user preferences page, there is a section on exporting borders and captions.  On my settings, charts and tables were unchecked.  It seems like another thing I would want to set globally.  I just happened to read the help section on the Clipboard Zoom feature.

0 Likes
kbiesemans
New Contributor

This is an extremely interesting finding!

I just tried it in a test report, but I don't get the same result. If I change the clipboard zoom to the maximum of 400%, the quality of the image gets better. At the same time I also see a lot of white space arount the image. See the following example.

Export.jpg

In a regular export it requires maybe just some manual work, but in NPrinting this is a real issue. Does someone know how I can solve this?

0 Likes
lubicz99
Valued Contributor

I did experience some of that too recently.  What version of QV are you using?  Try copying your image of a chart or graph to the clipboard and pasting it into Word and see if it fails the same way

0 Likes
kbiesemans
New Contributor

Mike, thank you for your quick feedback.

I tried it on two pcs:

  • QlikView 11.2 SR12 64bit on Windows 8.
  • QlikView 11.2 SR5 64bit on Windows Server 2008

I tried as well NPrinting as manual copy to Word.

Everything I try has the same result.

Do you remember in which case you experienced the same as me?

0 Likes
lubicz99
Valued Contributor

I am still on SR9.  I was considering upgrading to SR12, but have not done it yet.  I did a presentation on Nprinting at a user group meeting on Friday last week and experienced the error you are getting.  I used someone else's laptop which may have had the same version you have.

I need to do some more testing here.  Do you have the exe files to install SR 9 back on one of your workstations?  That seems to be the only difference I can see at this point.

0 Likes
daniel_kusiak
Contributor II

Hi, i have the same problem.

The objects like list box look better. But charts or tables are shrinked with a lot of blank space around them.  Im using QlikView 11.2 SR11 64bit on Windows 7.

0 Likes
lubicz99
Valued Contributor

That is peculiar for sure.  It only fails exporting a chart rather than a straight table.  I am out of the office today, but will circle back and do some more testing on this next week.

0 Likes
lubicz99
Valued Contributor

I have found the answer to the issue with the charts and tables shrinking on export.  It turns out there is a two step process to insure that your images are exported properly.  I have tested this and it works quite well.  I was doing a presentation at a user group meeting on Nprinting in Ohio this month and a consultant named Damian Eralio was able to fill in the missing step 1 in the process.  If you are not going to a user group meeting on a quarterly basis, I strongly recommend you find one in your area.  If you are in the Indiana or Ohio vicinity, send me a message and I will link you up. 

  Image Quality Improvement - 2 Step Process.PNG

0 Likes
mwoolf
Honored Contributor II

I know "Macros are Bad", but this code can be used to set the end users' ClipBoardZoom percent:

set up = ActiveDocument.GetApplication.GetUserPreferences

up.ClipboardZoom = 120

ActiveDocument.GetApplication.SetUserPreferences up

Version history
Revision #:
1 of 1
Last update:
‎07-27-2015 10:17 AM
Updated by: