Qlik Community

QlikView Documents

Documents for QlikView related information.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Warning on using QVD for Mapping Load

rwunderlich
Not applicable

Warning on using QVD for Mapping Load

This information is current as of QV 8.5.

If a QVD is used as input to a MAPPING LOAD, mapping will not work if the QVD loads optimized. For example:

Map1:
MAPPING LOAD * FROM codes.qvd (qvd);

Map F1 USING Map1;

Field F1 will not map. You will receive no warning of this problem.

The Reference Guide documents this restriction:

Mapping load does not support the use of QVD files as input source. The QVD must first be loaded to a table and then a mapping load can be made.

Here is an example of the workaround suggested by the Ref Guide:

TempMap:
LOAD * FROM codes.qvd (qvd);
Map1:
MAPPING LOAD * RESIDENT TempMap;
DROP TABLE TempMap;

Forcing an un-optimized load is another workaround. This technique is not documented in the Ref Guide but it seems to work reliably in QV 8.5. There is no guarantee it will work in future releases.

Map1:
MAPPING LOAD * FROM codes.qvd (qvd) WHERE 1=1;

The "WHERE 1=1" clause will force an un-optimized load.

Labels (1)
Comments
stephen-a_redmo
Not applicable
I ran into this problem yesterday and managed to "fix" it by accident. (On v9) I assumed that the data in the QVD wasn't clean so applied a Trim() function to one of the field - this, of course, caused the QVD to load un-optimized and solved my problem (though not because of my own brilliance!) Good to know about this. Stephen
Not applicable
I spent a day banging my head against a brick wall on this. Thanks for the heads up.
stevedark
Not applicable

Apparently this restriction has been removed in QV10 SR2 - but I have not tried it in a production evironment yet.

- Steve

jason_michaelid
Not applicable

This also goes for MAP...USING.  If field MyField1 is loaded as part of an optimized QVD load, then MAP MyField1 USING MyMap1 will NOT work. MyField1 is left just as it is - no warning!  If you break the optimized load then it works as expected.  This is on v11 SR1.

Been flummoxed by this for over an hour - thanks Rob!

Jason

stevedark
Not applicable

Hi Jason,

Is there a a reason that you are using MAP USING rather than an ApplyMap?  The problem doesn't exist any more with the latter.  For a discussion of the differences please see here: http://community.qlik.com/message/224985

- Steve

Version history
Revision #:
1 of 1
Last update:
‎05-07-2009 08:43 PM
Updated by: