Qlik Community

QlikView Extensions

Discussion Board for collaboration on QlikView Extensions.

Highlighted
aadilmadarveet
Valued Contributor

Google Maps extension - unsafe script issue

Hi All.

I am using a google map extension that i took from this thread (and yes, its modified to my needs now). I have attached the js file that i am using.

the problem i have now is, everytime this extension runs on any browser some of the scripts are considered as unsafe scripts and the browser shows a warning like this in chrome.. and a similar warning appears on firefox as well. 

chrome-js-shield-error.png

Could someone please help me understand, which part of js is making the browser identify the script as unsafe.

The Map looks like below.

map-view.png

Attached is the JS that i am using for this map.

Thanks,

Aadil

1 Solution

Accepted Solutions
Employee
Employee

Re: Google Maps extension - unsafe script issue

It happens because your mixing http and https sources into your loadLibs, you should choose only one method

View solution in original post

3 Replies
mbm
New Contributor III

Re: Google Maps extension - unsafe script issue

Aadil,

It would be helpful to have an example QVW and the full QAR file in order to test, but my guess is that you may be facing an issue because you are referencing unsecured scripts. Try loading the google libraries using https:

https://www.google.com/jsapi

https://google-maps-utility-library-v3.googlecode.com/svn/tags/markerclustererplus/2.0.1/src/markerc...

Or try the attached script and see if it helps.

Employee
Employee

Re: Google Maps extension - unsafe script issue

It happens because your mixing http and https sources into your loadLibs, you should choose only one method

View solution in original post

aadilmadarveet
Valued Contributor

Re: Google Maps extension - unsafe script issue

Thank you!