Qlik Community

QlikView Extensions

Discussion Board for collaboration on QlikView Extensions.

Highlighted
Not applicable

Quickmap - extension remains blank

EDIT:

I'm one step closer to the solution. The issue does not seem to be a server version, but the installation under https (the other servers have http).

Apparently the script was blocked because the server is installed under https, however the script called from openlayers is under http.

A quick google search reveiled that you can also unblock 'unsafe scripts'. Doing this does solve the problem... but allowing 'unsafe scripts' everytime is not the best solution.

A possible solution would be to remove the <s> and install only http, but are there any other ideas?

Thanks!

Screen Shot 2014-11-13 at 17.21.26.png

Hi,

I've been using several mapping extensions so far, but as of now the best one I've encountered is the KML extension call Quickmap by Briand Munz (see the github repository for the latest version: brianwmunz/QuickMap-QV11 · GitHub). This extensions is easy to implement and easy to modify to your application's style scheme.

However, on one of our servers the extensions does not work, the extensions shows blank (server is setup with SR8). On our other servers, SR4 and SR5, the extensions seems to work perfectly. See beneath for the two screenshots.

Would any of you know what the issue might be? Has anyone tested the extension on SR8 before?

Second question, more on the side. The current script currently runs the openlayers streetmap (http://www.openlayers.org/api/OpenLayers.js). Does anyone have any experience as to modify the default setting of the maptype? Next to the already quite beautiful coloured version, there are a number of alternatives. Such as the rather cool black/white version which I think if a bit more suited to map on heatmaps.

Thanks in advanced,

Boris

Not working on server with SR8:

Screen Shot 2014-11-04 at 12.31.25.png

Same qvw working under SR 4 and SR 5:

Screen Shot 2014-11-04 at 12.32.27.png

1 Solution

Accepted Solutions
MVP & Luminary
MVP & Luminary

Re: Quickmap - extension remains blank

Hi Boris,

one possible solution would be to use a local OpenLayers.js file like I did on my OpenLayersMap extension. But you will need also download and prepare (stub definition.xml file) the /img and /theme folders. Hope this helps..

- Ralf

2 Replies
MVP & Luminary
MVP & Luminary

Re: Quickmap - extension remains blank

Hi Boris,

one possible solution would be to use a local OpenLayers.js file like I did on my OpenLayersMap extension. But you will need also download and prepare (stub definition.xml file) the /img and /theme folders. Hope this helps..

- Ralf

Not applicable

Re: Quickmap - extension remains blank

Hi Ralf,

Thanks for answering, I believe that would be the solution.

I've solved this by a three step approach:

1. run the openlayers.js on your server, this will ensure you don't need to refer to a http site for the api. (see the app from ralf becher, OpenStreetMap Extension Object, he does this here)

2. call the local openlayers.js script on in the script.js of quickmap

2. in de openlayers.js refer to https://stamen-tiles.a.ssl.fastly.net instead of the a.tile site. (trick of maps.stamen.com)


Voila!


cheers,

boris

Sidenote: you can alter the type of map by the url extension in the openlayers.js, what a nice addition to the extension would be is to choose the type of map to plot onto in the front-end (work in progress).

I personally like the toner-lite: maps.stamen.com / toner-lite