Qlik Community

QlikView Extensions

Discussion Board for collaboration on QlikView Extensions.

Highlighted
bhelms
Contributor

Web Page Viewer Problem

We are trying to implement the Web Page Viewer into one of our applications and are having trouble with it. It seems to work fine on our desktops and on the server locally, but when we publish it to the AccessPoint it no longer works. The object doesn't even show up. If I try to re-create it on the AccessPoint, the object shows, but nothing shows inside it? Anyone seen this problem before? I've tried both the Web Page Viewer and Web Page Viewer 2 extensions, they both do the same.

8 Replies
tlorimier
New Contributor III

Re: Web Page Viewer Problem

I presume you are using an extension.

Did you install the extension inside the webserver ? On server the extension must be install in the following directory : QlikViewServer\Extensions\Objects\"your extension".

This path can be modify in the QMC.

Hope this help.

Not applicable

Re: Web Page Viewer Problem

Hello Brian, I have exactly the same problem.

I developed a model with a SVG map in it, therefore the QV must be set to WebView format. When I access the model locally (from my computer) it works fine, but, when i upload to the Company's Server (Access Point), to share with all users, the WebView option isn't available, so the map.

Hope that somebody will help us.

tlorimier
New Contributor III

Re: Web Page Viewer Problem

You don't have to enable WebView on the server because it is in "web" view when you access via the QMC.

Is the extension object is blank ? Or does it seems to do something and crash after ?

Not applicable

Re: Web Page Viewer Problem

It's just blank.

Sorry, but, what is QMC?

When I open via Access Point by Chrome the webview seems to work, but the map doesn't.

When I open via Access Point by QV desktop app the webview and the map doesn't work.

When I open locally by QV desktop app both work.

bhelms
Contributor

Re: Web Page Viewer Problem

I attached a picture in the original post of my issue. The object shows up, but doesn't actually show anything. It doesn't appear to ever attempt to do anything either. I can see the extension is available, but when I try to create one, it does the same thing, the object shows up, but doesn't show anything. Hope that helps.

tlorimier
New Contributor III

Re: Web Page Viewer Problem

My fault for using the wrong term : QMC means QlikView Management Console, it is your admin panel when you are on the server.

What I wanted to say was "Access point".

So how do you install the extension on your server ? Do you double click on the .qar or you do something different ?

naziralala
Contributor

Re: Web Page Viewer Problem

I would like to know if we can design a web portal using qlikview?

dloman92
New Contributor

Re: Web Page Viewer Problem

I am about 4 years late on this...but has anyone found a solution to this? I have this exact problem and haven't been able to find a solution online.