Qlik Community

QlikView Extensions

Discussion Board for collaboration on QlikView Extensions.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

svgMap not displaying correctly.

Hello Experts,

     We're trying to implement svgMap into one of our applications, however once we include the map into the application the svg images are not shown unless A) "Zoom selected regions" is selected and B) No region is selected, for the functionality we need the zoom function is not convenient, so we'ld like to disable it. Also whenever a user selects a Region on the map, all the drawings just vanish.

     Some extra info. If we enable the background color for the map, it is always shown even if the map isn't.

     Any advice is appreciated, thanks.

     I've tried the following solutions.

  • Re installing svgMap removing the last version from my computer (Downloaded May, 13th, 2015 from github)
  • Simplifying the color expression, to a plain color "=rgb(255,0,0)" allows us to select a region without issues, however still breaks without the Zoom selected regions checkbox
  • Creating a new app with only map data hasn't been useful.

Thanks in advice

Tags (3)
6 Replies
rbecher
Not applicable

Re: svgMap not displaying correctly.

Hi Manuel,

I was facing similar problems and have created a simple SVG File viewer extension. It has less featires than svgMap but I think it's more stable, especially in QlikView Desktop:

ralfbecher/QlikView_Extension_svgFile · GitHub

- Ralf

bmz
Not applicable

Re: svgMap not displaying correctly.

I'd probably recommend switching to Ralf's extension if you're only needing to support modern browsers.  The one I made was built to work in older browsers and thus used Raphael and other libraries that would be completely unnecessary if you don't have to worry about old browsers.  It just got to be too much old code, and I'm not able to recreate these errors.

The code will be about 80% lighter too I'd think.

I was thinking about porting my QlikSense svg extension back to 11, but with Ralf giving a good start, maybe I'll just contribute to his project (if he's open to it and posts it to Branch ).

rbecher
Not applicable

Re: svgMap not displaying correctly.

bmz ..it's already there and in GitHub. Feel free to contribute!

bmz
Not applicable

Re: svgMap not displaying correctly.

ah...just got back from holiday so I missed it.  Thanks!

Not applicable

Re: svgMap not displaying correctly.

Hi guys,

You've both done great jobs with these extensions, so first of all congratulations ;-)

I've been trying to modify svgMap in order to display my country (Portugal) and it's working great, but I want to enhance it in a new way - I want to make the map look like this: http://1.bp.blogspot.com/-ie500nD4JK4/Us3OFwFAxMI/AAAAAAAAREI/9weGit91-uY/s1600/filledmap6.jpg

Do you think it is possible? Can you give me some hints on how to make this work?

Thanks in advance,

Miguel

rbecher
Not applicable

Re: svgMap not displaying correctly.

Hi Miguel,

you can hire someone to build this..

- Ralf