Qlik Community

QlikView Integration

Discussion Board for collaboration on QlikView Integration.

Announcements
Customers, Partners & Luminaries only: You're invited to a Data Analytics Roadmap session. Read More
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor II
Contributor II

Migration of QlikView Web Server to IIS

Hello,

the migration of our QlikView Web Server to IIS has failed. We performed the following steps:

1. Backup C:\ProgramData\QlikTech

2. Deinstall QlikViewServer

3. Install IIS and configure

4. Reinstall QlikViewServer

5. Copy Backup to C:\ProgramData\QlikTech

The result was a IIS-Website that was unable to access QlikViewserver.

In the QMS was the config of the old Qlik View Webserver.

We don’t want to reconfigure our Qlik View Server. What is the best way to do it?

We are very thankfull for your help.

Thanks in advance.

Frank Reußner

Version:

QlikView 11.20

Windows Server 2012 - IIS 7

1 Solution

Accepted Solutions
Highlighted

I have a set up where I have a QlikView Web Server on the same server as the QlikView Server on the LAN, and another IIS server installation in the DMZ both pointing to the same QlikView Server and it works fine.

I do not think you need to deinstall / reinstall the QlikView Server at all.

Just

  • Stop the QlikView Web Server Windows service
  • Install / configure the IIS server and the QlikView Settings Service
  • In QMC | System | Setup | QlikView Web Servers
    • Create a new entry for the IIS server

Then test it all works ok and when you are confident deinstall the QlikView Web Server and remove it from the QMC.

View solution in original post

5 Replies
Partner
Partner

Hi,

Follow below thread pdf guide step by step

QlikView Server Installation Step by Step

proven solution, so much helpful.

Regards,

Highlighted

I have a set up where I have a QlikView Web Server on the same server as the QlikView Server on the LAN, and another IIS server installation in the DMZ both pointing to the same QlikView Server and it works fine.

I do not think you need to deinstall / reinstall the QlikView Server at all.

Just

  • Stop the QlikView Web Server Windows service
  • Install / configure the IIS server and the QlikView Settings Service
  • In QMC | System | Setup | QlikView Web Servers
    • Create a new entry for the IIS server

Then test it all works ok and when you are confident deinstall the QlikView Web Server and remove it from the QMC.

View solution in original post

Highlighted
Contributor II
Contributor II

Thank you for your quik reply.

I'm not finished yet, but it seems to work nicely, without deintalling QV Web Server.

Thanks

Frank Reussner

Highlighted
Partner
Partner

Hi Bill,

with reference to your comment on having 2 web servers, one IIS and the other Qlik webserver... I have a situation whereby I have a Qlik server installed on the same box as IIS which it where the Accesspoint is installed.  I want to move the IIS to a completely different server.

You have mentioned that all the IIS server requires is being configured correctly and having the Qlikview settings service running... in order to do that, I assume I would need to install Qlik server in its entirity on the new server and then disable all the qlik services except the settings service and then configure the QMC on the main Qlik server to point to the new webserver?

can you detail the steps a little more if possible?

appreciate the help,

doug

Highlighted

On the new server for IIS the only Qlik bit you need to install is the QlikView Settings Service.