Qlik Community

QlikView Integration

Discussion Board for collaboration on QlikView Integration.

Not applicable

QlickOCX Problems, not working at all.

Hi to all,

I'm trying to develope an aplication in C# that loads a QVW document. I've read all the documentation I've found related to QlikOCx and I think I've followed all the steps to registry the OCX.

1- I've registered the OCX

2- I've registered the qvp

3- Open new visual studio 2008 C# project (3.5 Framework, 32bits) and add the QlikOCX control in the toolbox.

And now, here is my problem. I cannot drag a drop the control to my code window, the name is in grey and i cannot select it. I've also tried the following code and I get the exception HRESULT: 0x8000FFFF (E_UNEXPECTED) when I try to open the document.

The code:

QlikOCX document = new QlikOCX();

document.OpenDocument(filename,user,pwd);

Thank you in advance for the answers...

2 Replies
Highlighted
Partner
Partner

QlickOCX Problems, not working at all.

You should use AxImp.exe (C:\Program Files (x86)\MicrosoftSDKs\Windows\v7.0A\Bin\) utility to generate wrapper class for QlikOCX control that can be hosted on a Windows Forms.

Not applicable

Re: QlickOCX Problems, not working at all.

Thanks for the answer but...

I,ve already tried this but it doesn't work. The thing is that I don't have any AxImp in side "\v7.0A\Bin\"... my AxImp is in "\v6.0A\Bin\". Perhaps this is the reason why it's not working...