Qlik Community

QlikView Integration

Discussion Board for collaboration on QlikView Integration.

Announcements
Announcement: Certain actions are currently causing a Page Not Found error. This is a known issue and we are working with the platform vendor to investigate and resolve it.
Highlighted
SlayerTech
New Contributor

R.ScriptEval() function not working in Qlikview

Hi, 

I am trying to integrate R in Qlikview.

I successfully established the connection between SSE to Rserve (gRPC listening on port 50051).

Also, I Updated the Settings.ini file with SSEPlugin=R, localhost : 50051

But I cannot run the function R.ScriptEval() (example function) in my Qlikview Desktop. 

it throws an error (Error in expression: R.SCRIPTEVAL is not a valid funciton).

I am not sure what I am missing here. 

Any sort of advice regarding my issue would be really helpful.

Thank you

2 Replies
MVP & Luminary
MVP & Luminary

Re: R.ScriptEval() function not working in Qlikview

According to your screenshot, you appear to have some extra spaces in your settings.ini. There should be no spaces.

 SSEPlugin=R, localhost:50051

SlayerTech
New Contributor

Re: R.ScriptEval() function not working in Qlikview

Hi Rwunderlich,

Thanks for looking into my issue. I tried with changing the code as you suggested (removed the spaces) but it still doesn't work. 
Is there any other process I am missing while integrating the Plugin other than SSEtoRserve and changing the Settings.ini file?