Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Not applicable

Access point does not authenticate from outside the network.

I can load documents from access point within my internal network but when i try to access from outside the network using public ip's then it opens login page but does not authenticate , it says login failed in an alert , any idea to resolve this?

6 Replies
Not applicable

Re: Access point does not authenticate from outside the network.

I guess your Authentication is set to "NTLM" (Windows Users). So as long as you are in the same domain (client and server) the authentication is working. As soon as you are using a computer from outside your windows domain, the access point does not recognise you.

Check your setting in the Management Console: System -> Setup -> QlikView Web Servers -> Authentication -> Type.

regards,

marcel

bibopipo
Contributor II

Re: Access point does not authenticate from outside the network.

Hi,

I think you should create a local user on the QLIK server and the problem should be solved

bibopipo

jeffmartins
Contributor II

Re: Access point does not authenticate from outside the network.

Hi mkhaliq13,

Are you using your login with the network domain ? The login should be domain\user.

Regards

Not applicable

Re: Access point does not authenticate from outside the network.

Hi ,

Thanks for the reply.

My settings are as below.

QVS -> Security

Authentication

Clients : Prohibit anonymous

Anonymous Account : On local computer

Authorization

NTFS Authorization


QVWS -> Authentication

Authentication : Always

Type : NTLM

Login Address : Alternate Login Page (Web Form)

Can you suggest what will be the configuration to make it accessible outside the network.

Not applicable

Re: Access point does not authenticate from outside the network.

Have you tried to log in with "domain\user" as jeffmartins has suggested?

That should actually work with your settings.

Otherwise see this ticket: http://community.qlik.com/message/319506

with QV 11.02 there seems to be a bug fix.

Not applicable

Re: Access point does not authenticate from outside the network.

Hi ,

Well I am not having any domain implemented in network , Somehow I have managed to recognize myself from outside the network using following settings.

QVS -> Security

Authentication

Clients : Prohibit anonymous

Anonymous Account : On local computer

Authorization

DMS Authorization


QVWS -> Authentication

Authentication : Always

Type : Custom User

Login Address : Alternate Login Page (Web Form)

But now the problem is when user logged in and tries to open any document then browser asks for authentication and strange thing is that even if i cancel that dialog document opens successfully , Although in authorization tab of that particular document i have selected "All Authenticated Users" , One thing more when I select default login page instead of alternate login page this dual authentication does not happens , but I want to use alternate login page , any ideas?

Community Browser