Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Not applicable

Chart modification

Hi there,

I know this must be kind of an easy one but i spend all day yesterday and i could not find a solution.

I have a bar chart that looks like in the fisrt attached image. There is a large empty space under the two bars that serves no purpose.

How can i delete that space  and make it look like in the second attached image?

Thank you all in advance!!!

Tags (2)
1 Solution

Accepted Solutions

Re: Chart modification

Uncheck Synchronize Zero Level for Expression-Axes on the Axis tab of the properties screen

edit: never mind, got the wrong option, try checking the Continuous option for the Dimension Axis on the Axis tab of the properties screen


talk is cheap, supply exceeds demand
9 Replies
fdelacal
Valued Contributor

Re: Chart modification

keep tight control and shift, so you can change the height and width of the object

Hope it helps you

Regards

Not applicable

Re: Chart modification

Hi there,

Thanks for your quick response .

Unfortunately this does not work. It was one of the first things that i tried myself.

It resizes all the chart , both the bars and the empry space under them.  I end up with a smaller version of what i already have.

fdelacal
Valued Contributor

Re: Chart modification

can you add a qvw example file?

Thanks

er_mohit
Honored Contributor II

Re: Chart modification

in chart properties -->presentation tab

adjust bar distance (2) and cluster distance (5)

or you can enable the x axis scrollbar

hope it helps......

see the image

bar.png

Not applicable

Re: Chart modification

Hi there,

i do not have a dimension in the bar chart. Only 2 expressions.

The bar distance and cluster distance are already set to the values that you propose and because ther is no dimension i cannot enable the x axis scrollbat option.

er_mohit
Honored Contributor II

Re: Chart modification

so,its an preview style that the chart takes that much space itself..

if you would trying to add dimension then using properties it covers space as you want.

u seen that when you go on style tab  in chart properties it shows the preview without add dimension you can't merge it.........

hope it helps you.

Re: Chart modification

Uncheck Synchronize Zero Level for Expression-Axes on the Axis tab of the properties screen

edit: never mind, got the wrong option, try checking the Continuous option for the Dimension Axis on the Axis tab of the properties screen


talk is cheap, supply exceeds demand
Not applicable

Re: Chart modification

that did not do it either...

Not applicable

Re: Chart modification

Thank you very much!!!

Your second answer was the right one!!!

Community Browser