Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Announcements
Talk to Experts Tuesday, Live Q&A, September 22: Moving from QlikView to Qlik Sense. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Drop-down select under Ajax Client problem

In a table box, a field can be tagged to have a drop-down select arrow, and so acts as a cheap & cheerful listbox. In the ordinary client, the property for sorting is effectively State = AutoAscending, which is useful as possible selections float to the top.

Under the Ajax client this does not seem to be honoured (the state is ignored), making multiple subselections difficult. Is there any straight fix for the Ajax client (before I explore other fixes like having only selections displayed or adding a listbox)?

Thanks

Prune

5 Replies
Highlighted
MVP & Luminary
MVP & Luminary

Looks like this problem: Drop-down select in tables not showing in AJAX

So, if the Selection Indicators setting is set to disabled you can try enabling it again.


talk is cheap, supply exceeds demand
Highlighted
Not applicable

Dear Gysbert,

Alas, the link doesn't work: I get "Access to this place or content is restricted. If you think this is a mistake, please contact your administrator or the person who directed you here."

However, it doesn't sound like the problem: the drop-down select does show, but the possible selections (usually in white) haven't floated to the top: which makes it useless if the list is long.

Thanks,

John B

Highlighted
Employee
Employee

Turn on "Selection Indicators"

Highlighted
Not applicable

Dear Clever Anjos,

They are turned on: they are visible, and the drop-down is displayed. It is just that the list is correctly sorted in the ordinary client but not under Ajax.

Thanks,

John B

Highlighted
Not applicable

Hello,

I am having the exact same problem as John.

Some fields of my straight table are not displayed in the order having white values on top and grey values below when I click on the drop down button in ajax mode. Values are just displayed from A-Z , no whites on top.

The sort settings are correct, or at least similar to the settings of those fields which show a correct sort order.

I can not figure "a trick" to change the sort order and do not understand why this behaviour only occurs to some fields of my datamodel.