Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

paolocamerini
New Contributor III

Expansion Icons disappearing when image is used as a Dimension

Good morning (at least here in Italy is 9:30 am) everybody!

I'm having an annoying issue with the access point:

whenever I use an image as Dimension in a pivot table (in my application I use a "smoking" "no smoking" .jpeg to distinguish areas in venues) everything works fine as long as I use the PC client. But when people access through the Access Point they report me that they see no expansion icon therefore they cannot expand or collapse the further/previous Dimensions.

Same happens in webview.

Images are bundled as info, however they doesn't work even in the simple image form.

Anyone experienced the same and found a workaround?

Here I attach an image to show the issue.

7 Replies

Re: Expansion Icons disappearing when image is used as a Dimension

Does a right-click on this dimension and choosing the collapse/expand-feature from the context-menu work?

- Marcus

paolocamerini
New Contributor III

Re: Expansion Icons disappearing when image is used as a Dimension

Yes but I find that to be less practical and, moreover, the report has to be optimised for mobile users and it would be really hard with a small device to open a shell to collapse and expand

Re: Expansion Icons disappearing when image is used as a Dimension

Ok. in general the feature of collapsing/expanding is available and worked. I think this meant that the Z-level of the icon and from the image has a different order within the access point and it might be changeable with an extension (I don't know if there are already extensions for a pivot which then could be used for adjusting the css for it).

But I'm not sure if it's a big difference from a small device then hitting the small icon will be also quite difficult.

- Marcus

santhosh_k_n
Contributor

Re: Expansion Icons disappearing when image is used as a Dimension

Hi Paolo,

Try opening the report in IE client rather than in AJAX client.

hope this helps.

BR,

SK

paolocamerini
New Contributor III

Re: Expansion Icons disappearing when image is used as a Dimension

Basically this issue can be addressed to the layer of the expand/collapse icons?

paolocamerini
New Contributor III

Re: Expansion Icons disappearing when image is used as a Dimension

This solves the issue, however with Apple or Android devices it won't work...

Re: Expansion Icons disappearing when image is used as a Dimension

I think the icons will be there and will be overlaid from the picture. To be sure you might need to have a look on the source-code from the website (in firefox ctrl + u) - whereby if I look on one I see only javascript.

Another method to check if the icons are there will be to set the picture for a testing to full transpareny.

- Marcus

Community Browser