Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Not applicable

Google Maps not displaying

Please see attached word document with screen shot to see my problem. Earlier today everything was working fine, but then suddenly I started getting this image instead of the map.  Has anyone else experienced this? I thought maybe it would be due to usage limits, but I'm the only person using it. Also, I don't see where it's actually referencing my api code when calling the image so I'm not convinced it's due to usage.

Google Map code in editor:

 

// Google Maps Key
// get a key here http://code.google.com/apis/maps/signup.html

gmap_key = 'I have my key typed in here';
max_zoom_level = 17; //maximum value 17

// Variables required for calculating map
// No need to change these
var_pi180= '=pi()/180';
var_lat_offset= '0';
var_mc2= '=256*pow(2,$(var_zoom))';
var_mc1= '=256*pow(2,($(var_zoom)-1))';
var_mid_lat= '=min(latitude)+(1+var_lat_offset)*((max(latitude)-min(latitude))/2)';
var_mid_long= '=min(longitude)+(max(longitude)-min(longitude))/2';
var_zoom= '=max(aggr(if(max( round(256*pow(2,(_zoom_level -1)))+( longitude *((256*pow(2,_zoom_level ))/360)) )-min( round(256*pow(2,(_zoom_level -1)))+( longitude *((256*pow(2,_zoom_level ))/360)) ) <map_size_x AND max((256*pow(2,(_zoom_level-1)))+((0.5*log((1+(sin((latitude)*pi()/180)))/(1-(sin((latitude)*pi()/180)))))*((-256*pow(2,_zoom_level))/(2*pi()))))-min((256*pow(2,(_zoom_level-1)))+((0.5*log((1+(sin((latitude)*pi()/180)))/(1-(sin((latitude)*pi()/180)))))*((-256*pow(2,_zoom_level))/(2*pi()))))<map_size_y,_zoom_level,1),_zoom_level))';
var_maptype= '=if(isnull(only(maptype)),fieldvalue( '&chr(39)&'maptype'&chr(39)&', 1 ),maptype)';
map_size_x= '640';
map_size_y= '400';

SET HidePrefix='_' ;
// Field required for calcualting best zoom level
_zoom_level:
Load RecNo( ) as _zoom_level autogenerate(max_zoom_level);

maptype:
LOAD * INLINE [
maptype
roadmap
mobile
satellite
terrain
hybrid
]
;

set hideprefix = 'maptype';


Code in Dynamic Image: 

='http://maps.googleapis.com/maps/api/staticmap?center='
&

var_mid_lat
&','
&

var_mid_long&'
&zoom=$(var_zoom)'&'
&maptype='&

var_maptype&'
&size='&

map_size_x&'x'&

map_size_y&'
&sensor=false'

Tags (1)
1 Solution

Accepted Solutions
mov
Esteemed Contributor III

Re: Google Maps not displaying

The picture in the attachment means that you've overused the limit of free usage.  Wait 24 hours, and it will be working again.

2 Replies
mov
Esteemed Contributor III

Re: Google Maps not displaying

The picture in the attachment means that you've overused the limit of free usage.  Wait 24 hours, and it will be working again.

Not applicable

Re: Google Maps not displaying

I had a hard time believing it...but you were right, it's working fine today. thanks!

Community Browser