Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Not applicable

Google Maps stopped working

Hi,

Google maps has just stopped working in all of my projects? I havent changed anything the map is just now blank :/

Has this happend to anyone else? and does anyone know why?

Thanks

1 Solution

Accepted Solutions
fdelacal
Valued Contributor

Re: Google Maps stopped working

change in properties of the color to

='http://maps.google.com/maps/api/staticmap?center='   &   num(var_mid_lat, '##############', '.', ',' )   &   ','   &   num(var_mid_long, '##############', '.', ',' )   &   '&zoom=$(var_zoom)'   &   '&maptype='&var_maptype   &   '&size='&map_size_x&'x'&map_size_y   &   '&key='& 'AIzaSyAABZIVacmXaH_m5XNM2PzcJo3uDr12Rzk' & '&sensor=false'

hope that helps you

12 Replies
anantmaxx
Contributor III

Re: Google Maps stopped working

You need to ahve a dedicated internet connection, also view-> web view must be selected

Regards,

anant

Not applicable

Re: Google Maps stopped working

thanks for your help anant

I have tried web view and my interent is on, is that what you mean? and its still not working

I am using just the standard map that before you could view not in webview

anantmaxx
Contributor III

Re: Google Maps stopped working

What do uou mean by standard map? and where it is not working in desktop or in qlikview access point

Regards,

anant

Not applicable

Re: Google Maps stopped working

Sorry I mean just the first google maps plug-in that was available, I know there was another one that could only be viewed in webview,

And it is not wokring in desktop

fdelacal
Valued Contributor

Re: Google Maps stopped working

change in properties of the color to

='http://maps.google.com/maps/api/staticmap?center='   &   num(var_mid_lat, '##############', '.', ',' )   &   ','   &   num(var_mid_long, '##############', '.', ',' )   &   '&zoom=$(var_zoom)'   &   '&maptype='&var_maptype   &   '&size='&map_size_x&'x'&map_size_y   &   '&key='& 'AIzaSyAABZIVacmXaH_m5XNM2PzcJo3uDr12Rzk' & '&sensor=false'

hope that helps you

Not applicable

Re: Google Maps stopped working

Hi,

I also have a similar problem. The map in the attached dashboard has stopped appearing.

Please help!

Regards,

Rahul

woertzmuttenz
New Contributor III

Re: Google Maps stopped working

HI,

Do you solve your problem ?

I have the same since about 1 month, I tried every solution from this forum, unsuccessfully :-(

Is there a new HowTo about Maps in QV ?

Thanks you

Thierry

fdelacal
Valued Contributor

Re: Google Maps stopped working

can you share your exaplme Thierry Doppler

regards

woertzmuttenz
New Contributor III

Re: Google Maps stopped working

Hi,

Here the script :

// Google Maps in QlikView

// V0.9 - October 1st 2008  © Copyright QlikTech International AB 2008 / AES

// Google Maps Key

// get a key here http://code.google.com/apis/maps/signup.html

gmap_key = 'ABQIAAAAZMxmMuZNX-jEVxaxtY6QhBT2yXp_ZAY8_ufC3CFXhHIE1NvwkxQwpGhizTzhu-7fd_ZDnyREtJ4Cmw';

max_zoom_level = 15; //maximum value 17

// Variables required for calculating map

// No need to change these

var_pi180=        '=pi()/180';

var_lat_offset=    '0';

var_mc2=        '=256*pow(2,$(var_zoom))';

var_mc1=        '=256*pow(2,($(var_zoom)-1))';

var_mid_lat=    '=min(latitude)+(1+var_lat_offset)*((max(latitude)-min(latitude))/2)';

var_mid_long=    '=min(longitude)+(max(longitude)-min(longitude))/2';

var_zoom=        '=max(aggr(if(max( round(256*pow(2,(_zoom_level -1)))+( longitude  *((256*pow(2,_zoom_level ))/360)) )-min( round(256*pow(2,(_zoom_level -1)))+( longitude  *((256*pow(2,_zoom_level ))/360)) ) <map_size_x AND max((256*pow(2,(_zoom_level-1)))+((0.5*log((1+(sin((latitude)*pi()/180)))/(1-(sin((latitude)*pi()/180)))))*((-256*pow(2,_zoom_level))/(2*pi()))))-min((256*pow(2,(_zoom_level-1)))+((0.5*log((1+(sin((latitude)*pi()/180)))/(1-(sin((latitude)*pi()/180)))))*((-256*pow(2,_zoom_level))/(2*pi()))))<map_size_y,_zoom_level,1),_zoom_level))';

var_maptype=    '=if(isnull(only(maptype)),fieldvalue( '&chr(39)&'maptype'&chr(39)&', 1 ),maptype)';

map_size_x=        '400';

map_size_y=     '400';

SET HidePrefix='_' ;

// Field required for calcualting best zoom level

_zoom_level:

Load RecNo( ) as _zoom_level autogenerate(max_zoom_level);

maptype:

LOAD * INLINE [

    maptype

    roadmap

    mobile

    satellite

    terrain

    hybrid

];

In the Map > Coulours :

='http://maps.google.com/staticmap?center='

&

num(var_mid_lat, '##############', '.', ',' )

&

','

&

num(var_mid_long, '##############', '.', ',' )

&

'&zoom=$(var_zoom)'

&

'&maptype='&var_maptype

&

'&size='&map_size_x&'x'&map_size_y

&

'&key='&gmap_key & '&.jpg'

I tried with another Key, and with this Post : http://community.qlik.com/message/335706 .

But the backgroup is still white ...

Thanks

Community Browser