Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

paul_ripley
Contributor

How to amend 'Send to Excel' format

Hello

Is it possible to 'send to excel' a table but the numbers be in number format rather than as text?

Thanks

Paul

6 Replies
simondachstr
Valued Contributor III

Re: How to amend 'Send to Excel' format

They should be exported as number format automatically unless you have at least one row which contains a string. If you still struggle I recommend explicitly formatting your expressions using num() or by setting the formatting in the chart properties.

paul_ripley
Contributor

Re: How to amend 'Send to Excel' format

Thanks Martin, there is one row that is a string.  I cant see in the chart properties though how I can force it to be treated as a number.  The column is a dimension rather than an expression.

MVP
MVP

Re: How to amend 'Send to Excel' format

You could try Document Properties | Number and set a numeric format for the dimension field. I am not sure whether that will override QV's data type logic in the the export, but its what I would try.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
simondachstr
Valued Contributor III

Re: How to amend 'Send to Excel' format

This will be tricky then - try loading your dimension as a dual field. Maybe that could help (didn't try it!).

jeremy123
New Contributor III

Re: How to amend 'Send to Excel' format

Hi Paul, I've been down this road a few times, this will work if have your number format in your QlikView table exactly the same as in excel. This is usually set in your regional settings on your windows control panel. If they are identical excel will recognize them as numbers. It's usually the digit grouping that causes a mismatch.

paul_ripley
Contributor

Re: How to amend 'Send to Excel' format

Thanks Jonathan, this worked for me.

Thanks everyone for your advice.

Paul

Community Browser