Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

MVP
MVP

Indent Mode does not display higher dimensions properly when collapsed

Hi

If you have a pivot table with multiple dimensions but only one expression, and use Indent mode, when the higher dimensions are collapsed, they are no longer displayed fully, even though the space is available. See the first pic (date has been pivoted, one expression):

t2.png

If you expand any one of the second level dimensions, then they display fully. But initially I need to display it at this level, and this is ugly.

If I add a second expression, everything works as it should. See the second pic:

t1.png

Has anyone got suggestions on how to get the full text of the second dimension to display with only a single expression in the picot?

I have resorted to a dummy expression (returning an empty string: = '') and hiding the vertical separator lines, but this causes a problem if exported to Excel.

Jonathan

Tags (1)
10 Replies
MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

No one else experienced this problem?

MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

Hi Jonathan,

I tried to reproduce, but failed. Could you upload a small sample?

And, on what version are you?

MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

I can reproduce similar, version 10.00.9282.8 SR4 64-bit.  For me, expanding and collapsing has no effect, but adding a second expression does fix it just as with your example.  I've seen lots of issues with indent mode over the years.  They seem to come and go with versions, as we would expect with bugs.  It feels kind of like half the time they forget to QA indent mode when they release a new version.  They check normal mode, and if it works, they call it good.

I believe I typically leave no room for the legend for the dimension at the top, which gives me the space to expand out the final dimension to give room, but that shouldn't be necessary, of course.

Highlighted
MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

Stefan

I get this in V10 SR5 (9516) and V11 SR1 (11282). See attached example (Desktop 32 bit). It contains two pivots, one with one expression and one with two.

Thanks

Jonathan

MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

John Witherspoon wrote:

I believe I typically leave no room for the legend for the dimension at the top, which gives me the space to expand out the final dimension to give room, but that shouldn't be necessary, of course.

John

I am afraid I don't understand this. Could you elaborate a little please.

Regards

Jonathan

MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

Jonathan,

I get "Access denied" error when trying to open the document. Is section access enabled?

Regards,

Stefan

MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

Stefan

My mistake - forgot to remove the section access. Corrected version attached.

Regards

Jonathan

MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

Jonathan,

I see what you are talking about.

If you expand the dimensions once, then auto size by double clicking, the size of the columns should fit your dimension values length (even after collapsing and expanding again).

The difference to the two expression version seems to be that the horizontal dimension label is in the same line as the vertical labels (as with multiple expressions, you get an extra line), which seems also to change / affect the automatic sizing of labels and dimension columns.

I agree that this handling could be a lot more user friendly.

I think this is also what John was talking about, fiddeling around with the column sizes.

Regards,

Stefan

P.S: Tested also on QV11 32bit, I must admit currently on IR version, need to upgrade this machine some time...

MVP
MVP

Re: Indent Mode does not display higher dimensions properly when collapsed

Stefan / John

Unfortunately, that removes the key advantage of indent mode when used (as in this case) with long labels. The real table has many more dates on it, so horizontal space is at a premium and indent mode is supposed to use horizontal space more efficiently.

So I guess I will have to fall back on to my workaround and create a second dummy expression that has no label and is whose value is an empty string. That solves the truncation, but the empty columns are exported into Excel and have to be deleted or hidden.

Here's hoping that Qliktech fix this behaviour soon!

Thanks for looking at this.

Jonathan