Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Highlighted
siddharth_kulka
Contributor II

Input Box Conditional Bug

Scenario:

Passing variable v_INP=x;y;z in Input Box

There are 3 different charts conditionally shown for x,y,z input box selections.

Issue:

The chart with condition v_INP='z' doesnot show up.

To be precise, the chart with conditional show from the last value in the variable(z in this case) doesnot show up.

So if I delete z from the variable and select y in Input box, the chart with the condition v_INP='y' doesnt show up.

If i put a semicoln at the end of z(which we normally dont do), the chart for z appears, but there is an extra space entry in input box(Obv not the solution)

Using 9.0 SR 6. Done the same thing so many time b4, but never witnessed this

Any thoughts. Did any1 experience this?

Regards,

Siddharth

Tags (4)
1 Solution

Accepted Solutions
siddharth_kulka
Contributor II

Input Box Conditional Bug

Kiran,

I saw PurgeChar and got the hint.

Actually I had mistakenly pressed enter after z and hence it was taking a line feed character and hence the issue.

Once I got the cursor to the end of the previous line, it worked as expected. NOT a BUG

Thanks N Cheers!

View solution in original post

6 Replies
Not applicable

Input Box Conditional Bug

This might sound basic but I want to get something confirmed before we move on. Can you make a text box with condition:

=IF(v_INP,'Z',1,IF(v_INP,'Y',2,IF(v_INP,'X',1,0)))

This indicates whats happening in the inbox and might provide better insight on the issue (ofcourse you might have already tried it, if so please share the details).

Kiran.

siddharth_kulka
Contributor II

Input Box Conditional Bug

Kiran,

I had tried it all.

if(v_INP='z',1,0) returns 0 and doesnot show the chart

BUT, if I put a semicolon after z in the variable list values, then 1 is returned and the chart appears

Logically, it is considering a space or missing value after Z, as we are not putting a termination semicolon(which is wierd and unusual).

hence 'z' is not matching v_INP(which is I suppose z+space or z+missing).

Not applicable

Re: Input Box Conditional Bug

Can you try, if(trim(v_INP)='z',1,0)?

If this too fails try the below two: PurgeChar(v_INP,' '), PurgeChar(v_INP,chr(10))

By the way I never faced it using v10 SR2,3.

Kiran.

siddharth_kulka
Contributor II

Input Box Conditional Bug

Kiran,

I saw PurgeChar and got the hint.

Actually I had mistakenly pressed enter after z and hence it was taking a line feed character and hence the issue.

Once I got the cursor to the end of the previous line, it worked as expected. NOT a BUG

Thanks N Cheers!

View solution in original post

Not applicable

Input Box Conditional Bug

Siddharth,

One thing to note in the List of Values in is that its not a expression(even thought it calls as expression). Hence if you have any formula it wont work. Sad thing is that it always uses ; as delimiter. I wish QV get this as expression with dynamic delimiter.

Kiran.

siddharth_kulka
Contributor II

Input Box Conditional Bug

Yup...I agree

Kiran,

Can you take a look at one of my posts below. Will like to know your views.

http://community.qlik.com/message/150401#150401

Thanks,

Siddharth