Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

datanibbler
Esteemed Contributor

Lines in a multi-diagram - display figures BELOW the line?


Hi,

I have many multi-diagrams in my charts. Currently, I have a line representing a presence_quota.

- I have not ticked the checkbox "figures in diagram", but in the expression_options ("show_value", the bottommost one), I have entered a formula making those figures appear only for today and yesterday.

- On the "presentation" tab of the properties dialog, I have ticked the checkbox "show figures inside segments" (on the left)
=> In the columns, the figures appear in the middle instead of on_top_of_the_columns which is better.

My current issue is this:

- I have a line (not an expression because I don't want it to shrink to a dot when a single day is selected) at a value of 96% which is our company-wide objective for the presence quota

- The line which represents the factual presence quota is usually just below that value, seldom above - but usually it is close to it.

<=> Because of that, the figures, which are displayed ABOVE the line, are covered by that line.

=> That's why I asked if I could have the figures displayed BELOW the line - since the line itself is usually below the fixed target_line, that would be fine.

Thank you!

Best regards,

DataNibbler

2 Replies

Re: Lines in a multi-diagram - display figures BELOW the line?

Not tried - just as idea. Create this expression twice and put the second one on the second axis, customize this axis a bit lower as the first and hide it, show your figures but hide this line or make the color transparent. Another possibility could be to put two charts one above the another and hide from one all unless the figures - but by many charts is this not very nice.

- Marcus

datanibbler
Esteemed Contributor

Re: Lines in a multi-diagram - display figures BELOW the line?

Hi Marcus,

thanks for the idea! However, I already have two axes, so that won't work.

"Moving" the axis using the minimum/ maximum settings didn't work yet for me, either.

Well, I have been able to make it better at least in the meantime by making the fixed target_line dotted and making the figures black, bold and a bit bigger. It's not optimal, but now the figures can be just about seen.

Thanks a lot!

Best regards,

DataNibbler

Community Browser