Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

udaya_kumar
Valued Contributor

Listbox issue

Hi,

I have a listbox, user has to select it to see the tables and charts.

I have restricted the user in selecting only one value from the listbox.

I have selected one value in the QlikView Client, I published it to the server.

When i see the same file in the AccessPoint, multiple selection has happened for that listbox.

I dont know why it is happening like that.

can somebody help me?

Tags (2)
16 Replies
Not applicable

Re: Listbox issue

Hi

In between developing on your client and publishing to the server, have you emptied the data model at all (perhaps to check in to source control). If you empty the data model (or you open without data) then these field level properties will be removed.

I get around this by applying a select trigger on opening the document then firing a macro to set the "One & only one" property value.

rajeshvaswani77
Valued Contributor III

Re: Listbox issue

Could be related to your plug-in. Test on both IE plug-in as well as AJAX plug-in to see if it works.

Not applicable

Re: Listbox issue

May sound strange but did you remember to save?

If you did, have you reloaded the document and did it fail once?

udaya_kumar
Valued Contributor

Re: Listbox issue

Hi everyone,

Even in both Ajax and IE plugin, it shows the same thing.

multiple values are getting selected in the server.

Reload failed sometime back, but i refreshed it again, it ran well.

udaya_kumar
Valued Contributor

Re: Listbox issue

Hi Nigel,


I didnt empty the data model and i didnt open it without data.

It was working fine before, but suddenly i dont know what happened,

it is happening like this. Multiple values getting selected only in Server, but not in Client.

udaya_kumar
Valued Contributor

Re: Listbox issue

Hi,

The problem was that, I used the Subfield function in the trigger to limit the user in selecting multiple values.

Because of that, multiple values were getting selected in the server. I guess, trigger was not working properly in the server.

But how do i limit the user from selecting more than one value?

I should not use "always only one value selected".

Not applicable

Re: Listbox issue

Why would you not use "always only one value selected", this is what it

is for?

udaya_kumar
Valued Contributor

Re: Listbox issue

Hi Nigel,


I dont want it to use because the user has to select the value from the listbox.

At the beginning, all the listboxes will be empty. then user will select the value based on his view of seeing the data. so if i can't use always only one value selected.

Can we do it with expression?

Because of triggers, it gave me the problem so.

Not applicable

Re: Listbox issue

Well, as far as I know you can only run a check that will provide a

warning to the user that they can only select 1 value (if they have

selected more than one).

Other option:

Populate the list box

Use a trigger to select the "default" option

Run a macro that sets the property of the list box to one and only one

This will have issues also, in that you then cannot clear the value

because of the above property being set, but it might be worth a try to

see if re-populating the list box clears the property. Bear in mind that

in order to set the property of one and only one, you must have a value

selected already which is why I have said to select a default. If you

cannot select a default value in the list box then I'm afraid you're not

going to be able to do anything apart from issue a warning that more

than one value is selected.

Community Browser