Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

joaquinlr
Valued Contributor II

Lost with missing values

Hello guys:

I have the attached an app with a Fact Table and a master calendar.

I have created an evolution chart based on the calendar date, and it works with data but what happens when I choose the WebSite de-DE ??

I can see the 16th day in the x-axys but I can't see the 0 value, this WebSite has not information for this day.

I need help. What should I do to see this missing 0 value for 16th ?

I've tried joinning this two tables with LEFT, RIGHT, INNER, OUTER, and NATURAL (only JOIN) but it doesn't work.

Thank you very much,

Joaquín

Tags (4)
1 Solution

Accepted Solutions
Employee
Employee

Re: Lost with missing values

The website has no data for this day so the join to the calendar table will not result in a date.

In this situation, you have to force the dimension to show 'all values' (below) and the missing values will show as zeroes (as  you have already correctly unselected 'suppress zero values' on presetnation  tab)

Untitled.png

7 Replies
Employee
Employee

Re: Lost with missing values

The website has no data for this day so the join to the calendar table will not result in a date.

In this situation, you have to force the dimension to show 'all values' (below) and the missing values will show as zeroes (as  you have already correctly unselected 'suppress zero values' on presetnation  tab)

Untitled.png

Re: Lost with missing values

Hi,

another solution could be to add a term, that delivers (zero-)values at the missing dates:

QlikCommunity_Thread_143137_Pic1.JPG.jpg

QlikCommunity_Thread_143137_Pic2.JPG.jpg

But of course the "Show all values" check box is the better choice ...

hope this is of any interest nevertheless

regards

Marco

Re: Lost with missing values

Like this

Regards

ASHFAQ

joaquinlr
Valued Contributor II

Re: Lost with missing values

Hi jpe

Check "Show all values" hasn't been enoughm the chart still the same.

But, thank for help

Joaquín

joaquinlr
Valued Contributor II

Re: Lost with missing values

Hi Jonathan Poole

Sorry Jonathan, it works. I have just checked the option in a wrong version of the app

Thanks again.

Joaquín

joaquinlr
Valued Contributor II

Re: Lost with missing values

Thanks also to MarcoWedel and ashfaq_haseeb

joaquinlr
Valued Contributor II

Re: Lost with missing values

Hi guys:

I need a bit more help.

I've created this new post Lost with missing values. Part II

Thank you for your help.

Joaquín

Community Browser