Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Not applicable

Missing legend label after conditional dimension

I had a bar chart with two dimensions - and the labels were displayed correctly. The first dimension was the bar across the bottom (no label needed) and the last dimension differentiated different bars designated by colors in the legend. In this case, I had Chart Properties -> Dimensions -> For the second Used Dimension I had the Label box checked and the desired label listed. The legend label was displayed correctly on right side of chart.

Since then, I added several conditional dimensions to replace the first dimension, so there are several conditions that change what is showed along the X-axis, but the last dimension has stayed the same (Label box still checked). The problem is that the label at the top of the legend is no longer visible.

MissingLabel.jpg

Tags (2)
4 Replies

Re: Missing legend label after conditional dimension

Try to Click on your chart, then press simultaneously ctrl + shift then click on the red area of the legend and move / resize it

Not applicable

Re: Missing legend label after conditional dimension

Cool - Learned something new...but unfortunately that doesn't change anything. The red line starts right above the first item in the legend list regardless of how big it is.

Not applicable

Re: Missing legend label after conditional dimension

Hi,

PFA For Ur issue Solution Document.

Regards,

Damu

sivarajs
Valued Contributor II

Re: Missing legend label after conditional dimension

Make your year,month,week,logdate fields as cyclic group.

You can create cyclic group in Chart properties-> edit groups(left side bottom) -> name a group and add fields.

Add the cyclic group to dimension and check if the problem still exists.

Community Browser