Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor

Need to find and clear "Always One Selected" or other limiting function.

As implemented as a server Web Dashboard, the "Always One Selected" features seems to be enabled.  At one time this was a desired feature and now it is not desired.  There are 10 sheets.  ...One Seletected... is related to a Date column.  Each sheet has been investigated for having the 'box checked' and none were found.  The forced selection is only active in the server Web Dashboard instance.  In the Qlikview instance in development or WebView the forced one selected function is not active.

(I do know that the Always One Selected selection is grey and only available when one is selected)

Is there a way to search / find what sheet and object might be driving ...one selected...? 

Is there another method to drive ...one selected... that I might search and attempt to clear function?  

Might there be a conflict between the local version and dashboard version that needs to be addressed?

5 Replies
Highlighted
Partner
Partner

Always one selected value is stored at field level. If you load the application  without any fields all "always one selected value" will disappear.

  • Add an exit script in the very beginning of your app.
  • Store your app.
  • Remove the  exit script 
  • Reload the whole application  as you  normally do.

 

Plees ekskuse my Swenglish and or Norweglish spelling misstakes
Highlighted
Digital Support
Digital Support

Scott, did Vegar's solution work for you?  If so, do not forget to give him credit and let others know that worked by clicking on the Accept as Solution button on his post.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Contributor
Contributor

It is not clear to me what resolves the issue.  

All of the “always one selected” field selections were removed and the issue persisted.

It is not clear to me which of the following solved the issue  

1. Clear IE browser data. 

2. Clear Chrome browser data. 

3. Remove last document state.  

4. Reboot PC.

5. Reload dashboard on pilot server. 

All of which were applied in various sequences in whole or partially .

 

Highlighted
Digital Support
Digital Support

Scott, check the Settings\Document Properties\Triggers tab, if you have an OnOpen trigger configured, see if by chance that points to a macro that is maybe setting things...  Only thing of which I can think that would potentially be making things persist.

You could also do a Ctrl-M which will bring up the Edit Module, so you can see if there are any macros configured there as well, and if there are, if they look to be setting Always One Selected on a field...

Cheers,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Partner
Partner

I actually have the same issue.

3. Remove last document state.   Does not make a difference.

5. Reload dashboard on pilot server.  Does not make a difference.

I removed one of the fieds that hade the setting "Always one selected", but it still shows up in Current selections. Although it is not possible to select or clear the field.