Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
richard_simpson
New Contributor III

QlikSense Server (June 2017) Map Object dimension problem

Hi Everyone & mto


Following on from the latest video (https://community.qlik.com/docs/DOC-6941) from Michael Tarallo which shows how the Map object works in QlikSense June 2017 WITHOUT the need for a KML file...

I have an issue that loading a City field into my app when running QLikSense Desktop and then plotting those cities in the map object works fine...

But when I import the app to QlikSense Enterprise Server (still the June 2017 version) the map object doesn't work?

The message is simply that the dimension called "City" is invalid.

I have tried creating a new map object in the hub on the server and then dragging the field city onto it, but it will not accept it as a dimension.

Could it be that the MAP doesn't work in the same way in QlikSense Enterprise Server (compared to QS Desktop) and still requires a KML file? (I understand that not needing a KML file is a very recent addition to the functionality of QlikSense which is something Mike Tarallo covered in his latest map video). But I can see the auto-generated script has tried to generate the tables _cityAliasesBase and _cityGeoBase.

Any thoughts on this would be greatly appreciated.

Thanks

Richard Simpson

Community Browser