Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Not applicable

Select report in access point

Hi All,

I have few reports in QVW with Conditions. It is working perfectly in desktop. After moving it to the server i'm unable to select the reports. Its simply goes grey out. When i disabled the conditions they are working fine in access point.

Does anybody experienced this before.

Sir, stevedark‌ i saw your post Reports not opening via AccessPoint | Qlik Community‌. My issue is similar to your comment in their.

Thanks

Walter

1 Solution

Accepted Solutions
MVP
MVP

Re: Select report in access point

Hi,

The IF part of that statement is superfluous, as the inner part returns a Boolean that can be used by the condition.  Try with simply this:

GetActiveSheetId()='Document\SH43'

As marcus_sommer‌ points out, the fact you have the 1 and the 0 in single quotes is making them strings, which may not evaluate correctly.  It's interesting it works in Desktop but not server - but there you go...

Hope that helps,
Steve

7 Replies
Not applicable

Re: Select report in access point

Hi Walter,

Do you have section access conditioned in the reports?

MVP
MVP

Re: Select report in access point

What code do you have in the Conditions?

If, rather than removing the conditions, you place in code that will always evaluate to true, e.g. 1=1, do the reports show correctly then?

I certainly have customers who have reports that show / hide on conditions and this works as advertised.

Which version of QlikView are you experiencing this with?

Steve

Not applicable

Re: Select report in access point

Hello Sir,

Thanks for the reply.

Heres is the conditoin : if(GetActiveSheetId()='Document\SH43','1','0')


its QV 11.2 SR10

Re: Select report in access point

Try to adjust your condition to something like:

if(GetActiveSheetId()='Document\SH43',true(),false())


'0' or '1' are simply strings and only false() respectively 0 will be treated as false and everything else is true.


- Marcus

MVP
MVP

Re: Select report in access point

Hi,

The IF part of that statement is superfluous, as the inner part returns a Boolean that can be used by the condition.  Try with simply this:

GetActiveSheetId()='Document\SH43'

As marcus_sommer‌ points out, the fact you have the 1 and the 0 in single quotes is making them strings, which may not evaluate correctly.  It's interesting it works in Desktop but not server - but there you go...

Hope that helps,
Steve

Not applicable

Re: Select report in access point

Thank you Sir,

Infact i applied your condition too.... It solved the issue.

Very helpful

Not applicable

Re: Select report in access point

Thank you Sir,

Thank you so much for your time.

Community Browser