Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Not applicable

Straight Table issue with dimensions and expressions from different tables

Hi guys,

Hopefully, there is a way to fix my current problem.

I have multiple tables in an application and for one straight/pivot table I need to show information related to two different tables in one row.

For example

      

HIDCostIDOpenDateActionDateCostCompleteddateActualCost1ActualCost2ReceivedBy
10126/03/201508/04/201510001/01/2015 Mr A
20224/03/201508/04/201520002/01/2015 Mrs B
30319/03/201508/04/201530003/01/2015 Mr C
40423/04/201527/04/201540004/01/2015 Mrs D
------5030

HID is one dimension and CostID is another dimension. Open date to completed date are all expressions that use data from one table with data related to HID.

ActualCost1 and ActualCost2 use information from a second table.

I want the cost of 50 and 30 to show on the row for the related CostID rather than show on a row with blanks which isn't useful.

Is there any way to get this work?

Thanks

4 Replies
ogster1974
Honored Contributor II

Re: Straight Table issue with dimensions and expressions from different tables

The issue is with your join on your 2 tables.

As long as CostID is present in both your tables Qlik will join on CostID automatically and fix your issue.

If there is no direct join you will need to use Set Analysis on your expresssions to join the values yourself.

MVP
MVP

Re: Straight Table issue with dimensions and expressions from different tables

I suggest that you post your qvw or a sample with the issue. But i agree with andy.weir, this is a data model problem.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
kuczynska
Contributor III

Re: Straight Table issue with dimensions and expressions from different tables

If the data is being displayed like this it means that the two tables aren't associated properly - how they are linked?

Not applicable

Re: Straight Table issue with dimensions and expressions from different tables

Thanks for all the responses. I'll see if I can post the qvw.

It does seem like the tables aren't properly associated

Community Browser