Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

Not applicable

Total Label repeats on each dimension column after export to excel

Dear all,

     Any one have any idea if this is the native bahavior ?

Any idea if it is possible to let the label show once ONLY ?

Thanks

1.) Created a straight table with TOTAL and type in TOTAL Label

StraightTableTotalLabel.jpg

2.) Then Export to Excel as got the following:

StraightTableTotalLabelExcel.jpg

6 Replies
Not applicable

Re: Total Label repeats on each dimension column after export to excel

I don't know if this is the usual behaviour of QV. But an idea for a workaround could be to label the second column with a space ' ', which would be invisible at export.

// sebablum

Not applicable

Re: Total Label repeats on each dimension column after export to excel

Sebablum, thanks for your reply.

What you mentioned could be done in Pivot table but not in Straight Table.

In Stranght Table, there is only one place for you to define the Total Label.

StraightTableTotalLabelProperty.jpg

Not applicable

Re: Total Label repeats on each dimension column after export to excel

Yes I see. Sorry, but I don't know a way out then. Maybe you should use Pivot Table and activate "Always fully expanded"?

Regards,

sebablum

Not applicable

Re: Total Label repeats on each dimension column after export to excel

No worry, it is good to exchange ideas because this always stimulate thought!

Change it to Pivot Table could be a solution but in my case, cannot because due I have to hide some columns while Pivot Table do not have Hide Column option.

Thanks for your sharing!!

jonbrough
Valued Contributor

Re: Total Label repeats on each dimension column after export to excel

Is EMPNO set as a dimension ? If so, trying setting as an expression only(EMPNO) and then setting no total for it.

Jonathan

Not applicable

Re: Total Label repeats on each dimension column after export to excel

Thanks Jonathan. My example above is just a sample and in my case, the straight table object is not that simple.

Seems like this is the native behavior of Qlikview and can only be solved using some work arounds like your suggestion.

Thanks again

Community Browser