Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

stevelord
Valued Contributor

Unable to move dimension columns on a straight chart?

Hi, All but one of my straight tables allow me to move any of my columns around.  I have one where the arrow-highlights appear and it looks like I'm moving the column, but the column ultimately stays where it was when I let go of the mouse button.  I have three other straight tables that are nearly identical except they have some expressions counting activities a/b/c, and this table has expressions counting activity d.  The tables all have columns like userid, first name, last name, office code, team name, then the expressions.  On the stubborn table, the team name is to the right of the expressions columns and it is not letting me drag it back to the left of the expressions columns.  Please let me know what I can try to solve this and get my team name dimension column back to the left of the expressions columns.  Thanks!

...and as I typed this, it occurred to me I can make an =TeamName expression and promote it to the top of the expressions as a clean hack...  But I'll chip correct answer credit to anyone who provides a solution for me to make the dimension column stay where I move it to.

1 Solution

Accepted Solutions

Re: Unable to move dimension columns on a straight chart?

Do you have any hidden columns in that straight table? If so, unhide them, then move the columns to where you want them and then hide the columns you want hidden again.


talk is cheap, supply exceeds demand
2 Replies

Re: Unable to move dimension columns on a straight chart?

Do you have any hidden columns in that straight table? If so, unhide them, then move the columns to where you want them and then hide the columns you want hidden again.


talk is cheap, supply exceeds demand
stevelord
Valued Contributor

Re: Unable to move dimension columns on a straight chart?

Perfect, thanks.  (Some of the columns had conditional shows enabled, and I just turned that off to rearrange them, then turned it back on.)

Community Browser