Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

datanibbler
Esteemed Contributor

Very simpleton question - selecting in chart_area?


Hi,

I have a very stupid problem:

=> Usually, when I click on one of the columns in a combochart, that dimension_value (date in my instance) gets selected unless I have ticked "Read only" in the properties_dialog.

<=> Right now, I have a diagram where that doesn't work.

Can anybody think of any other reasons?

Thanks a lot!

Best regards,

DataNibbler

9 Replies
mov
Esteemed Contributor III

Re: Very simpleton question - selecting in chart_area?

There is no such a thing as "stupid question"... :-)

Maybe you chart is "Detached"?

datanibbler
Esteemed Contributor

Re: Very simpleton question - selecting in chart_area?

Hi Michael,

no, it isn't. Strangely, I just tried clicking in another chart - which is usually set to "Read only", but I deactivated it - and that merely resulted in the dimension shrinking from five displayed days (only three with data) to three ;-) - and when I clicked once again, it reverted to five ;-O

Well, I don't really care - generally, I set all my charts to "Read only" to avoid users clicking around and becoming confused with what they see... only in this case, I would like to enable the user to see, for a given number of "events" that happened on a given day, which areas those happened in...

datanibbler
Esteemed Contributor

Re: Very simpleton question - selecting in chart_area?

Hi,

I think it may be that I have a locked selection in a field that I deleted in the meantime (by renaming it in the script). That happened before and I know that in that case, selections don't work on that particular field and in generall, things go awry...

I'll try.

Re: Very simpleton question - selecting in chart_area?

Nibbler

On occasion I find when developing in the QV Desktop I suffer from a Sticky Cache [like you having a field you have deleted persisting as defective zombie].

So when I get weird things happening in the QV Desktop then the first thing I do is close & restart it.

Best Regards,     Bill

mov
Esteemed Contributor III

Re: Very simpleton question - selecting in chart_area?

Maybe there are actions attached to the field selection...

datanibbler
Esteemed Contributor

Re: Very simpleton question - selecting in chart_area?


Hi,

no, there aren't.

Strangely, I just reverted one renaming_step (which was one line in the LOAD statement where I load a field called >Datum_AZ< and I had that loaded >...as %Datum< to link to my master_calendar.

I reverted it, so now it is again labeled >Datum_AZ< - and now the clicking works...

Err - yes, that's probably because... Hmm...

datanibbler
Esteemed Contributor

Re: Very simpleton question - selecting in chart_area?

Hi,

I again edited the LOAD statement so now I load the field Datum_AZ twice:

- once in the original form (with the original name) and

- once >  as %Datum< to link it to the master_calendar.

=> Now I could verify that the two date_fields seemingly have the same format.

<=> Still, in a diagram where I have the original field >Datum_AZ< as dimension, the clicking works whereas in a diagram with the dimension >%Datum<, it doesn't.

Well, in this instance this in itself isn't so critical as I have at least one record for every day in that table I loaded, so all the dates are there - but still I'd like to know what is happening...

datanibbler
Esteemed Contributor

Re: Very simpleton question - selecting in chart_area?


Hi,

to keep things moving here, I will abandon the search for the reason for now - but instead of using the original_name field, I will still use the link_to_mastercalendar field and just do without the possibility of selecting one single day - all the days of one week are selected by default, that is precise enough - I'll just build a second diagram, a straight_table with the dimension >%Datum< plus another dimension >Line_ID< which I calculate in the script, so I can uniquely identify every single event and display exactly the plant and area where it happened.

Best regards,

DataNibbler

datanibbler
Esteemed Contributor

Re: Very simpleton question - selecting in chart_area?

Hi,

I think me kicks a horse...

It works!

Apparently, Bill was right and a restart of the entire laptop was needed. I didn't think of that yesterday, I just restarted QlikView.

Too bad for the time that cost me yesterday... Well, it works and that's what counts.

I'll close this thread then.

Community Browser