Qlik Community

QlikView Layout & Visualizations

Discussion Board for collaboration on QlikView Layout & Visualizations.

hansdevr
Contributor II

When I open QVW I see strange things...

When I open a certain QVW I'm working on, I see this:

Anyone any idea why I don't see gauges and pics I'm expecting?

BTW, a single refresh or reload brings them back...

1 Solution

Accepted Solutions

Re: When I open QVW I see strange things...

I experienced this with QV 8 and QV 10 quite often and now with QV 11 very rarely. I think the reason for this behaviour is that you hit any limits regarded to available Object-RAM, timeouts by the calculations and maybe an issue with the caching-engine from qlik.

At first I would take a look on the used dimensions/expressions and trying to optimize them in combination with possible changes on the datamodel - to avoid calculated dimensions, aggr-functions, nested if-loops and maybe some more.

- Marcus

2 Replies

Re: When I open QVW I see strange things...

I experienced this with QV 8 and QV 10 quite often and now with QV 11 very rarely. I think the reason for this behaviour is that you hit any limits regarded to available Object-RAM, timeouts by the calculations and maybe an issue with the caching-engine from qlik.

At first I would take a look on the used dimensions/expressions and trying to optimize them in combination with possible changes on the datamodel - to avoid calculated dimensions, aggr-functions, nested if-loops and maybe some more.

- Marcus

hansdevr
Contributor II

Re: When I open QVW I see strange things...

Hi Marcus and thank you very much for your swift reply!!

I think you must be right there. There is a LOT going on in this qvw; it's a real hog. I will do the optimalisations you recommended! There are some quite complex set analysis functions going on here, and some nested ifs; the latter will be the first to go..

Community Browser