Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Announcements
BARC’s The BI Survey 19 makes it official. BI users love Qlik. GET REPORT
Highlighted
Not applicable

Can not login into the Access Point with Active Directory user

Hello all,

We have a Qlikview Server installation up and running. Configured to authenticate by Active Directory. Everthing is fine as long as we do the logins on the server itself. As soon as we want to login to the Access Point from another pc the authentication fails. It keeps prompting the login box for three times and then the screen 'freezes'.

Both machines are on the same domain. The accounts we tested on the server are no local users. So the connection with the AD is not the problem.

The account we are logged in with on the other pc is a domain account which is also configured in the management console as a CAL user.

Do we miss some firewall settings at the server side? At the moment we have port 80 and 4747 open.

Thanks,

Bram

10 Replies

Re: Can not login into the Access Point with Active Directory user

Hi Bram,

That sounds like if you had section access in your document, that authorizes with different credentials to those provided when the user logged on the computer.

The fastest way to check this is to modify the authentication into the AccessPoint in the QMC, System, Webservers, Authentication, Alternate Login Page (web form) where the user, before being granted to the AccessPoint will be prompted with a webform provided with the QlikView Web Server for username and password. This username and password must be that in the AD.

But, in the case that the section access does not have the NTNAME field populated with values equal to users in the AD, you get prompted three times, then denied.

The idea with this alternate login page is to verify whether or not you can see the AccessPoint, regardless whether or not you are able to open a document.

Hope that makes a little sense.

Miguel

Support
Support

Re: Can not login into the Access Point with Active Directory user

Can you post a screen shot of the login box your are getting? Are you running IIS or QVWS?

Bill

Bill - Designated Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Not applicable

Re: Can not login into the Access Point with Active Directory user

We are running on IIS7. We changed the login to the web form. The other pc keeps promtping the same login screen (see below). On the server with IE we do get the new web form but then we are unable to login. With firefox (on the server) we get prompted with a login box and when we login with the AD credentials we are shown the alternative web form login box. Also not able to login on with that browser.loginpage.JPG

Support
Support

Re: Can not login into the Access Point with Active Directory user

OK, this is a Windows issue and not Qlikview. I am assuming that the server that IIS is  a member of the domain?  I would check the  QlikView and QvAjaxZfc Virtual folders to make sure both are set for only Windows Authentication.

Bill - Designated Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Not applicable

Re: Can not login into the Access Point with Active Directory user

We already had windows authentication enabled on both folders. We disabled the other options. Nothing changed, too bad.

Could it be a firewall option? Because on the server the authentication is succesfull and on the other pc it is not?

Support
Support

Re: Can not login into the Access Point with Active Directory user

Well, you could try turning it off for a test. Are you going through a proxy? I have seen issues with that.

Bill

Bill - Designated Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Not applicable

Re: Can not login into the Access Point with Active Directory user

turned off the firewall, no result.

Also we are not behind a proxy.

We just looked into the windows event viewer. Every logon is succesfull but immediately gets logged off, for some reason.

Not applicable

Re: Can not login into the Access Point with Active Directory user

Hi Bram,

Did you find issue or resolution??

We have a server running for 18 months then behaviour changed to exactly how you described.

No Config/Admin/Maintenence being carried out at the time.

Any help appreciated.

Thanks

Tim

Not applicable

Re: Can not login into the Access Point with Active Directory user

Hi Tim,

I wasn't around when they fixed the LDAP connection. A colleague of my made a call to Qliktech and they helped him fix it.