Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Not applicable

Do we need Wow64 enabled?

We recently upgraded our test system from Windows Server 2003 to Windows Server 2008 and installed QlikView Version 10, SR4, build 9277.  In the System tab under About, in Section QVS, I noticed the Wow64 Mode is set to 'Not using Wow64'.  I believe Wow64 is what enables a 64 bit server to access 32 bit databases like MS Access.  We are using the Wow64 ODBC driver window to set up our connections to many different Access databases, and it is working but not quite as well as on Server 2003. 

Do we need to have Wow64 enabled in QlikView, and if so, how do I do that?  I cannot find any reference to this in the Server Manual. 

Thanks for any advice you can give.

Jackie Lee

4 Replies
Not applicable

Do we need Wow64 enabled?

I've never had an issue with this at any of my sites or on any of my local machines.

QV10 introduced the ability to force 32b access so you should have no difficulty using the Microsoft Jet 4.0 OLE DB provider (highly recommended) or if you have Office 2010 available, Microsoft finally released a 64b OLE DB provider for Access.

Not applicable

Re: Do we need Wow64 enabled?

Hi

Is there any option to Enable wow64 @ Qlikview Desktop  ?

Re: Do we need Wow64 enabled?

Why would you want to enable WoW64?

WoW64 is a Windows subsystem that is present on all 64-bit Windows systems. It allows you to run 32-bit applications on a 64-bit operating system. You can see it as a sort of translation layer. If you install QV-x86 on a 64-bit Windows, it will automatically use WoW64. If you install QV-x64 on a 64-bit Windows, it won't.

Peter

Employee
Employee

Re: Do we need Wow64 enabled?

The text 'Not using Wow64' means exactly that. It does not use WoW64 since it is a 64-bit program.

Further, the qvs.exe does not access databases at all. If you run scripts on the server or on the Desktop, the DB access is made by QVConnect32.exe or QVConnect64.exe. The QVConnect32.exe will use WoW64.

HIC

Community Browser