Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Announcements
If you are a Qlik Insight Bot user, join this collaborative group: JOIN GROUP
Contributor

In QMC schedule disabled, but still trying to reload

I had a Qlikview file that caused troubles so that the server got hung. I disabled the reload schedule of this file in QMC, but the next day I still received an email that the task x.qvw was failed. (And the server had to be rebooted again).

How is that possible?  How to avoid this in the future

disabled but still error.png

7 Replies
Highlighted
Support
Support

Re: In QMC schedule disabled, but still trying to reload

There are a few ways this can go wrong. The most common thing I've seen is the task being changed in the QMC, but that change not being written down to the QVPR. You can check the QVPR directly or use the Power Tools to check it. If that's the case, you'll probably want to change the QMS Chunk Size in order to read/write to the QVPR in a more stable way.

https://support.qlik.com/articles/000003187

 

 

Highlighted
Contributor

Re: In QMC schedule disabled, but still trying to reload

Hello Chris.

We don't use Publisher (As I understand, QVPR is related to the Publisher)

The reload of a document after I selected 'none' in QMC/Documents/Reload tab under 'Reload Schedule' occured only once: If a qvw is to be reloaded each morning and on a certain day I disabled it, the next morning I get an error (reload failed). After that one time try, it stopped. I think that after a reload, the scheduler of QMC already has the next reload moment in memory. Even if I disable the schedule, the next reload is still somewhere in its memory.

How to solve this.

Highlighted
Digital Support
Digital Support

Re: In QMC schedule disabled, but still trying to reload

Had to read things a couple of times to be sure I understood, so let me rephrase the issue for starters, you had a task that was running fine and then started causing issues on the server, so you disabled it by selecting None for the schedule on the Task properties, but the task is still running.  What this indicates is the Management Service is not able to communicate the change in the task to the Distribution Service for it to update its file, as the two services basically keep duplicate information of things, but if they cannot communicate, then changes to Management Service side will not get to the Distribution Service and it will continue to do what it has in its copy of the task information.  

The fastest solution to this one is likely to stop the Distribution Service in the Windows Services Applet, then rename the C:\ProgramData\QlikTech\DistributionService folder such that when you restart the Distribution Service, it will recreate the folder and the task information should be pushed from the Management Service to repopulate the task info to the Distribution Service.  I am not sure why things are not synchronizing though, and that could still be a problem if you rename the folder potentially, that may be the root cause of things here, and if that can be addressed, things may stop.  You can set the logging level on the Management Service to Debug in QMC\System\Setup\Management Service and the General tab settings, that may provide some further information on things.  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Contributor

Re: In QMC schedule disabled, but still trying to reload

It is indeed like your rephrase, but the strange thing is: the reload (after disabling) occures only once.

E.g. The file x.qvw runs every night at 02:00 h. On Monday morning I notice that x.qvw has a reload error and I disable this file (by selecting 'None'). Then on Tuesday this file runs in an error at 02:00h again. I take no action on that. Wednesday it does not happen again. --> The reload  only occured once after disabling.

 

Last few years this kind of issue occured several times (with several files) and normally nothing serious is going on: it is only one error; the server will go on. But why I started this thread is beacause the reload of file y.qvw caused a hung server on a certain day. I thought to solve it quick (temporary) by disabling the reloadschedule of this file in order to fix the file during the week (maybe an infinite loop or something). But Tuesday morning the server was down again when trying to reload y.qvw and I did not touch this file (except from disabling the schedule in QMC).... 

Highlighted
Digital Support
Digital Support

Re: In QMC schedule disabled, but still trying to reload

So, the only thing I can recommend the next time you do one of these, be sure you disable both the Trigger and the Task, as the only thing of which I can think is your not disabling the Trigger, and that may be what is causing things, but the trigger should not actually be able to run things if the task is disabled, so I am at a bit of a loss to explain how things are occurring at the moment, but I think if you disable both the Trigger and the Task, that may keep things from happening, sorry I did not just lead with this on my last post! 🙂  

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Contributor

Re: In QMC schedule disabled, but still trying to reload

Hello Brett

I don't know how to disable the trigger as well as the task

I only know selecting 'none'in the 'reload schedule' (printscreen)

2019-06-17 12_23_54-QlikView Management Console.png

Highlighted
Digital Support
Digital Support

Re: In QMC schedule disabled, but still trying to reload

Ah, sorry about that, my bad, I assumed you had Publisher, you just have the Reload Engine, so in that case, you have the right thing marked off, reset the schedule to the 'None' value as you have noted in your post, hit Apply, then uncheck the Enabled check box and Apply again, that should ensure you do not get anything orphaned I believe.  Apologies again for my bad assumption! 🙂

Cheers,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.