Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Announcements
Announcing the newest addition to the Qlik Community, Qlik Gallery! Learn More
Highlighted
Not applicable

Installing QVServer 10 using command-line arguments

Our installation media needs to incorporate QVServer10 as part of our product.  Previously, with QV8.5, we were able to pass command-line arguments to the installation and have it run silently.  However, I am having difficulty doing this with QV10.  When I attempt to pass command-line arguments, I get a Windows Installer dialog box listing the valid command-line options.  I tried using the /V"list of arguments" and /v"list of arguments" without success.  Looking at the QVServer reference manual, I found a section that said use msiexe -i exename /V"list of arguments", but that didn't work either.

Here's what I'm trying:

QlikViewServer_x64Setup.exe  /v"/qn INSTALLDIR="C:\Program Files (x86)\Sage Practice Analytics\InfoPOINT\DashBoardServer" ALLUSERS=2 NOCOMPANYNAME=1 NOUSERNAME=1 QVSDOCUMENTS="C:\Program Files (x86)\Sage Practice Analytics\InfoPoint\QlikTech" USERNAME="Practice Analytics" COMPANYNAME="Sage Software" ADDLOCAL=Qvs,QlikViewManagementService"

alternatively, I've tried

QlikViewServer_x64Setup.exe  /V"/qn INSTALLDIR="C:\Program Files (x86)\Sage Practice Analytics\InfoPOINT\DashBoardServer" ALLUSERS=2 NOCOMPANYNAME=1 NOUSERNAME=1 QVSDOCUMENTS="C:\Program Files (x86)\Sage Practice Analytics\InfoPoint\QlikTech" USERNAME="Practice Analytics" COMPANYNAME="Sage Software" ADDLOCAL=Qvs,QlikViewManagementService"

The installation runs fine if I just run the executable and walk through the InstallShield Wizard, but my charge is to install QV10 without any form of user interaction.

Any suggestions on how to address this would be gratefully appreciated!