Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Announcements
QlikWorld, June 24-25, 2020. Free virtual event for DI and DA gurus. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Internal Error - Server Connection Terminated

Hi!

I have installed my Qlikview applications on Qlikview Server.And accessing them from a cleint machine. Sometimes my access point is comming fine and applications are also running fine but sometimes "Internal Error - Server Connection Terminated" Comes on the page and access point is not displayed.

Does somebody has an answer to this. i am also attaching a screen shot.

Best Regards,

Rahul Tyagi.

Tags (2)
18 Replies
Highlighted
Employee
Employee

Internal Error - Server Connection Terminated

Are you using QvWebServer or IIS? What does the web server logs say? QVS logs?

Highlighted
Not applicable

Internal Error - Server Connection Terminated

Hi! Stefan,

I am using QvWebServer but IIS is also installed on my server.

I have cleared the logs and aging tried to open the Access Point through the URL. Again i am getting the same error and in the QvWebServer logs only these lines were printed.

2/13/2012 17:16:51.9849756 Information Request received [POST]: http://<Server IP:Port>//qvws.asmx

2/13/2012 17:26:52.0041756 Information Request received [POST]: http://<Server IP:Port>//qvws.asmx

Highlighted
Employee
Employee

Re: Internal Error - Server Connection Terminated

Does IIS need to be running? Otherwise, shut that down to not run them both at the same time.

Highlighted
Not applicable

Internal Error - Server Connection Terminated

My access point was comming for some time but when i stopped the IIS, access point also stopped comming, blank page was comming and now when i have started it again access point  is comming in a distorted way. i have atached a screen shot of it also.

Access Point.png

Highlighted
Employee
Employee

Re: Internal Error - Server Connection Terminated

Ok, so again - which one are you supposed to use in this configuration - QvWebServer or IIS? It's one or the other, not both. If you want to use IIS, then QvWebServer needs to be stopped, and vice versa.

Also, it seems you are accessing the AccessPoint via the IP-address - it's better to use DNS hostnames. Is there a reason for not doing this?

Highlighted
Not applicable

Re: Internal Error - Server Connection Terminated

Actually i am not using any of them intentionally . i think QvWebServer is used as default. Can u suggest me if how to use any one of them explicitely.

When i am using computer name instead of ip address in am not able to access the url.

i think using IP is more appropriate than using computername.

Highlighted
Employee
Employee

Re: Internal Error - Server Connection Terminated

Ok. If you are supposed to use QvWebServer, you need to stop IIS. At least make it not respond to port 80.

Regarding hostnames.. best practice is always to use DNS or NetBIOS hostnames. It is also the way the QlikView service interfaces are configured by default, and using IP instead can cause issues like you are seeing. If you cannot access AccessPoint via hostname, the fault is probably in your environment/machine rather than in QlikView.

Consult your IT people if you have DNS name resolution issues or alike.

Highlighted
Not applicable

Internal Error - Server Connection Terminated

Hi! stefan

i tried to open access point by hostname but it is not openiing up. then i went on the server and tried to open the access point by local host it opened , then i tried by sever IP it opened but when i tried by local host it again didn't open on server also.

I think the IIS is using port 80 can u tell me how to make it not respond to port 80. also does port 4747 also have any significanse in this.

Highlighted
Employee
Employee

Internal Error - Server Connection Terminated

To shut down IIS, do either of the following two:

1. Start > Run.. > cmd > net stop W3SVC.

or

2. Start > Run.. > services.msc > World Wide Web Publishing Service > Stop.

You might also want to change the service startup mode to "Manual" or "Disabled" to stop it from restarting and causing issues again.