Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Highlighted
Not applicable

Login page doesn't redirect to requested dashboard

Hello,

When the user try to access a qlikview application via a saved URL (like http:\\xxxxxx\QvAJAXZfc\opendoc.htm?document=xxxx), the application is opened if the user is already authenticated.


But if the user isn't authenticated, he's redirected to the login page (the URL in the browser is then like http://xxxx/qlikview/login.htm?back=xxxxx).
After he entered his login and password, instead of being redirected to the qlikview application, he's redirected to the access point (http:\\xxxxx\qlikview\index.htm).


Did we missed a setting ?
Any ideas ?


Thanks.
Claudia.

note : In ie debug mode, I noticed that in login.js, in the function CheckUrl(url, defUrl), defUrl is always returned instead of url (url contains the value of "back" parameter, but host and hostname are always empty even after the following code : if(l.host == "") { l.heref = l.href;})

Version  : 11.20.12235.0 SR5 64bits edition


3 Replies

Re: Login page doesn't redirect to requested dashboard

Hi

Use this url instrad

http://xxxx/QvAJAXZfc/opendoc.htm?document=xxxx&host=QVS@xxxx


Let me know if that worked.


Regards

ASHFAQ

Not applicable

Re: Login page doesn't redirect to requested dashboard

Hi Ashfaq,

Thanks for your answer.

It works with your solution, but i made a mistake when i wrote the URL.

We have to open the qv application with ie plugin, and so the URL is like this : http://<host name>/QvAJAXZfc/AccessPoint.aspx?open=&id=<qvw application>&client=Plugin 

So when i add "&host=QVS@xxxx" to this URL it doesn't work (http://<host name>/QvAJAXZfc/AccessPoint.aspx?open=&id=<qvw application>&client=Plugin&host=QVS@<hos...).

I also tried this : http://<host name>/QvAJAXZfc/opendoc.htm?document=xxxx&client=Plugin&host=QVS@<host name> but in this case the qv application is opened without the ie plugin.

So the problem seems to be linked to the ie plugin.

Regards,

Claudia.

Re: Login page doesn't redirect to requested dashboard

Hi,

Try with my suggestion and make sure you have set IE pluggin as default client.

Let me know if that worked.

Regards

ASHFAQ