Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

rothtd
Contributor III

Message: No Server – QV11 SR2

We have been running our environment (unchanged) for about a year and started noticing that our users were getting the red ‘Message: No Server’ on access point. We do see error messages in the Web Server logs and are working through them. The QVMC shows no issues and lists both QVS’s as fully functional. Given that this issue started appearing for seemingly no reason I wanted to ask the community if they have experienced this before.

Do you know what (at a high level) causes this error? Is it a communication error between the Web Server and QVS? [they are on the same physical server in our environment]

Is it possible that we crossed some sort of threshold like number of applications or load on QVS? (our QVS is only using a quarter of its memory, and barely any CPU).

Is it possible that a Windows patch was applied to IIS or OS and is causing this issue?

The QVWS logging level is set to ‘high’ – could the added load account for this? The log files are split daily and are < 10MB in size.

Anyone deal with this before?

Environment:

3 physical servers Win Server 2008R2, 56GB, 64-bit

QV 11 SR2 (11414)

Server 1:  QVMS, QVDS, QV Directory Connector

Server 2: IIS, Directory Connector, QVS (clustered with Server 3)

Server 3: IIS, Directory Connector, QVS (clustered with Server 2)

Sample QVWS error lines:

4/22/2013 08:24:23.1782533  Error    QVClient.Execute failed

4/22/2013 08:24:23.1782533  Error    System.Threading.ThreadAbortException: Thread was being aborted.

   at QVSWrapper.QlikViewServer.ExecuteXml(Action`2 i_Logger, String i_Command)

   at QVSWrapper.QlikViewServer.GetAdminDocListForUser(Action`2 i_Logger, String i_UserName, eDocumentListType i_ListingType, eExtendedDocInfo extendedInfo, IEnumerable`1 i_Groups, Boolean GroupListIsNames)

   at QlikView.AccessPoint.FileScan.<>c__DisplayClass3.<ScanQlikViewServerClusters>b__0(IQlikViewServerWrapper qvs)

   at QlikView.AccessPoint.QlikviewServerSetting.Try(Func`2 f, Func`1 fail)

   at QlikView.AccessPoint.FileScan.ScanQlikViewServerClusters(IEnumerable`1 servers, Action`2 logger, IUser user, Int32& liveQvsCount, Boolean respectBrowsable)

4/22/2013 08:29:52.2041806  Error    System.AggregateException: One or more errors occurred. ---> System.FormatException: Input string was not in a correct format.

   at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)

   at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)

   at QVSWrapper.QlikViewServer.GetServerStatus(Action`2 i_Logger, String& reason)

   at QlikView.AccessPoint.QlikviewServerSetting.<Ping>b__f(IQlikViewServerWrapper q)

   at QlikView.AccessPoint.QlikviewServerSetting.Try(Func`2 f, Func`1 fail)

   at QlikView.AccessPoint.QlikviewServerSetting.Ping()

   at System.Threading.Tasks.Parallel.<>c__DisplayClassf`1.<ForWorker>b__c()

   at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask)

   at System.Threading.Tasks.Task.<>c__DisplayClass7.<ExecuteSelfReplicating>b__6(Object )

   --- End of inner exception stack trace ---

   at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)

   at System.Threading.Tasks.Task.Wait()

   at System.Threading.Tasks.Parallel.ForWorker[TLocal](Int32 fromInclusive, Int32 toExclusive, ParallelOptions parallelOptions, Action`1 body, Action`2 bodyWithState, Func`4 bodyWithLocal, Func`1 localInit, Action`1 localFinally)

   at System.Threading.Tasks.Parallel.ForEachWorker[TSource,TLocal](IEnumerable`1 source, ParallelOptions parallelOptions, Action`1 body, Action`2 bodyWithState, Action`3 bodyWithStateAndIndex, Func`4 bodyWithStateAndLocal, Func`5 bodyWithEverything, Func`1 localInit, Action`1 localFinally)

   at System.Threading.Tasks.Parallel.ForEach[TSource](IEnumerable`1 source, Action`1 body)

   at QlikView.AccessPoint.QlikViewServerStatus.PingThread()

---> (Inner Exception #0) System.FormatException: Input string was not in a correct format.

   at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)

   at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)

   at QVSWrapper.QlikViewServer.GetServerStatus(Action`2 i_Logger, String& reason)

   at QlikView.AccessPoint.QlikviewServerSetting.<Ping>b__f(IQlikViewServerWrapper q)

   at QlikView.AccessPoint.QlikviewServerSetting.Try(Func`2 f, Func`1 fail)

   at QlikView.AccessPoint.QlikviewServerSetting.Ping()

   at System.Threading.Tasks.Parallel.<>c__DisplayClassf`1.<ForWorker>b__c()

   at System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask)

   at System.Threading.Tasks.Task.<>c__DisplayClass7.<ExecuteSelfReplicating>b__6(Object )<---

Thanks in advance for any input!

27 Replies

Re: Message: No Server – QV11 SR2

Hi,

I have seen that error linked to some different issues. One is related to DNS, and usually gets fixed when in the QMC everything that refers to the server name is changed to refer to its IP address.

Some others have to do with the .NET Framework pointers (sometimes because of updates). Usually running in the cmd.exe as administrator

lodctr /r

solves the issue.

Anyway, is there any identifiable pattern on the computers it happens? Or the type of users by license, group, time of the day, days of the week, documents?

Hope that helps.

Miguel

rothtd
Contributor III

Re: Message: No Server – QV11 SR2

No pattern yet, besides a random one.

I'm trying to start by getting a high level understand of what this error message is. Can you shed some light on the error from a high level? Is the 'no server' message stating that the Web Server is not recognizing that a QVS exists (at that instance in time)? I understand that AccessPoint scans the root folder as well when rendering to the end user – if there were issues reading the root folder would this error be displayed?

Thanks for your input.

danielrozental
Honored Contributor II

Re: Message: No Server – QV11 SR2

I believe the error means that the QVS doesn't respond to the QVWS/Accesspoint on time.

That could mean a network issue (if QVS and QVWS are not in the same machine), or that the QVS is too busy to respond to the QVWS.

Not applicable

Re: Message: No Server – QV11 SR2

I have seen the error, when the service is down. So maybe a reboot or a reboot of your service would help? have you looked?

Otherwise try an reinstall, that also helped sometimes.

rothtd
Contributor III

Re: Message: No Server – QV11 SR2

All services are up and QMC reports the system as fully functional. A reinstall of our production environment would be a difficult option, expecially for troubleshooting purposes. I think I'll hold off on that, unless I have a definitive reason for doing so. Thanks!

rothtd
Contributor III

Re: Message: No Server – QV11 SR2

Update:

Support stated that this error occurs when the Web Server cannot reach QVS or QVMS. The Management Service is interesting, as for me it’s on the same physical server as the QVDS. I notice that QVDS puts significant load on that box at times, and its possible the communication between QVMS and WS are being disrupted (causing this error message).

I also adjusted the CPU Affinity setting of QVS to keep a core open for other processes (I was allowing QVS to have all cores). In my environment, the web server is on the same physical box as QVS.

Partner
Partner

Re: Message: No Server – QV11 SR2

Hi rothtd,

I had a similar problem as yours, a random red message 'Message:No Server' on access point.

In my case, it was caused by an antivirus installed on Qlikview Server. My solution was put the qlikview folders (

C:\Program Files\QlikView, C:\ProgramData\QlikTech and the app folders)

in the exclusion list of the antivirus.

Are you using any antivirus in your server ?

Hope this helps you.

Regards

rothtd
Contributor III

Re: Message: No Server – QV11 SR2

Thanks for the tip - I just had our security team exclude the QlikView folders from scanning.

rothtd
Contributor III

Re: Message: No Server – QV11 SR2

Update - Support found in my logs that I have users hitting QV 11 SR2 with older plugins. That is true, we upgraded and not 100% of my user base is on the QV 11 SR2 Plugin version. According to the documentation (and our testing) it worked fine. True, from the users point of view it works - except they don't render any functionality newer then their plugin version. Support brought up a great point, that from the QVS side it might cause a bigger problem. They told me that this might be causing some stability issues in QVS. We are working to upgrade everyone now.