Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Highlighted
Not applicable

Missing document in AccessPoint

This one really has me stumpped. The symptom is that I cannot see the .qvw in AccessPoint although all settings seem to be configured to support this.

What I have done:

  • Built a .qvw on my local machine and copy/pasted it to customer's server - the same folder as all other .qvws in AccessPoint
  • Checked the folder and file security to ensure the correct users have access to the file
  • I have gone to QMC to ensure the access is enabled (QMC > Documents > select document > Server > Availability > select IE client and Full Browser > Apply)

Now the issues:

  • I go to Access Point and the document is not visible
  • I open QlikView Desktop > Open in Server... and cannot find the file
  • I go to the file system and open the .qvw and can see and modify everything in QlikView Desktop
  • (I am logged in as the same user for all the above scenarios)

What setting am I forgetting about??

1 Solution

Accepted Solutions
ramoncova06
Valued Contributor III

Re: Missing document in AccessPoint

I am assuming that the qlikview service is part of that administrators group, that would make sense as to why it was not seeing that folder, every time you create a folder you need to be sure that the qlikview service is granted admin access to

8 Replies
ramoncova06
Valued Contributor III

Re: Missing document in AccessPoint

do you have section access in the document ? if you do is your login the same to connect to the access point as in you server ?

has an shared and meta file being created ?

Not applicable

Re: Missing document in AccessPoint

No Section Access.

Meta and Shared files have been created since it was visible "for a short while" according to the customer. I can't attach them here due to data leakage controls at the customer site.

I have also tried removing these META nd SHARED files from the mounted folder.

buzzy996
Honored Contributor II

Re: Missing document in AccessPoint

can u try these steps,

1.go to where u published ur .qvw file on windows box path

2.right click on ur .qvw--properties--security tab-- click edit button--click add button--enter ur int id--search for it---OK--OK--OK.

TRY TO SEE FROM AP.

Not applicable

Re: Missing document in AccessPoint

I resolved this by adding "Administrators" to the list of users on the .qvw


Therefore my security config changed from:

User A (usera@email.com) w Full Control

User B (userb@email.com) w Full Control

User C (userc@email.com) w Full Control

to

User A (usera@email.com) w Full Control

User B (userb@email.com) w Full Control

User C (userc@email.com) w Full Control

Administrators (SERVERNAME/Administrators) w Full Control

Anyone know why it is required to have this user group added to the file permissions in order for it to be accessible by QlikView Server?

buzzy996
Honored Contributor II

Re: Missing document in AccessPoint

seems to be,section access implemented in ur .qvw,because of that.

Not applicable

Re: Missing document in AccessPoint

Interesting interpretation. I don't have section access within the application. In this implementation it's all managed through windows file / folder permissions and we allow dynamic CAL assignment to users depending on what files they have access to.

ramoncova06
Valued Contributor III

Re: Missing document in AccessPoint

I am assuming that the qlikview service is part of that administrators group, that would make sense as to why it was not seeing that folder, every time you create a folder you need to be sure that the qlikview service is granted admin access to

Not applicable

Re: Missing document in AccessPoint

This was indeed it. Thanks rampreetha!

Of course, it makes sense that teh account running the QlikView services must be added to the file / folder. This is an easy thing to miss!