Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

csellei
Contributor

PowerTools 1.1 - qv-user-manager not working

HI all,

I'm trying to get CAL list using qv-user-manager console:

qv-user-manager --list=CAL

I'm getting following error:

X:\APPS_PUB\SERVIDOR\Qv User Manager 11>qv-user-manager.exe --list=CAL

An error occurred creating the configuration section handler for system.serviceM

odel/behaviors: Attempt by method 'System.ServiceModel.Configuration.ServiceMode

lExtensionCollectionElement`1<System.__Canon>.CreateNewSection(System.String)' t

o access method 'qv_user_manager.ServiceKeyBehaviorExtensionElement..ctor()' fai

led. (X:\APPS_PUB\SERVIDOR\Qv User Manager 11\qv-user-manager.exe.Config line 9)

I added connection user into QlikVIew Management API local group within QMC server.

I also change .NET version referenced into config file:

Change     <supportedRuntime version="v2.0.50727" sku="Client"/>

To:             <supportedRuntime version="v4.0.30319" sku="Client"/>

but i'm getting same error.

Any ideas?

Best regards.

3 Replies
MVP
MVP

Re: PowerTools 1.1 - qv-user-manager not working

Hi Christian,

The two things that I ran into when using the QV User Manager were making sure you use the correct version for the version of the QlikView server.  Also ensuring that the server name is in the config file correctly (under end point address).  I would also double check the Active Directory group that you have created and added the user running the task to - this needs to exactly match what is expected by the routine.

The syntax I am using to call the exe is this:

"E:\QlikView Documents\Power Tools\Qv User Manager 11\qv-user-manager.exe" -l CAL

The different syntax for the parameters may also have a bearing.

Hope that helps.


Steve

http://www.quickintelligence.co.uk/

csellei
Contributor

Re: PowerTools 1.1 - qv-user-manager not working

HI Steve,

I'm using the correct version. It's working in other QlikView instalation with same version.

User and configuration seems to be ok.

I think there is something at the environment, .NET, some dll, etc. I just cant't figurate what.

I'll try syntax you are using.

Regards.

Christian.

alexdataiq
Contributor III

Re: PowerTools 1.1 - qv-user-manager not working

Hi, sorry to revive an old post but I'm facing the same issue. Did you found a solution for this?

Regards

Community Browser