Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

QVUser2019
New Contributor

QV Web Service / Server Performance

Hi,

We have been running QV without issue for a while now , however we have started to run into some problems.

Every so often our web server is not reachable via its standard QV URL or locally from the server itself, however once we restart the QlikView Webserver Service it immediately kicks back into life (althought this is already running).  In additon to this every few days the server loses connection completely (although pingable) and requires a restart.

Have trawled through event logs and we see Warnings like -

QVWebServer - Failed get client: host not found

QlikView Distribution Service v12.20.20700 - DSC Service is offline / DSC reported diconnected

We run all services on 1 Azure VM and are using QV version 12.20.20700.0

Thanks in advance for any help.

1 Solution

Accepted Solutions
Support
Support

Re: QV Web Service / Server Performance

Hello!

The way the issue presents itself (especially as you mentioned the server loses connectivity entirely after a few days), makes me suspect that we may be looking at the QlikView server service (qvs.exe) either exhausting available memory or otherwise crashing.

The only thing I can suggest at this point is to try and find the root cause of the issue by looking at a time window from shortly before until shortly after the issue in these logs:

  • Windows Server Event logs (application/system) in combination with the
  • QlikView Server Event logs and
  • QlikView WebServer logs

There's a blog post that dives deeper into the QlikView logs there- and helps in case this is a performance or crash issue as I assumed.

You can also search the error messages that you find in our support portal at support.qlik.com (just use the big search bar on the front page 😊) in case what you find doesn't match the blog post.

/Sonja

To help users find verified answers, please don't forget to use the "Accept as Solution" button on posts that helped you resolve your problem or question.

View solution in original post

2 Replies
Support
Support

Re: QV Web Service / Server Performance

Hello!

The way the issue presents itself (especially as you mentioned the server loses connectivity entirely after a few days), makes me suspect that we may be looking at the QlikView server service (qvs.exe) either exhausting available memory or otherwise crashing.

The only thing I can suggest at this point is to try and find the root cause of the issue by looking at a time window from shortly before until shortly after the issue in these logs:

  • Windows Server Event logs (application/system) in combination with the
  • QlikView Server Event logs and
  • QlikView WebServer logs

There's a blog post that dives deeper into the QlikView logs there- and helps in case this is a performance or crash issue as I assumed.

You can also search the error messages that you find in our support portal at support.qlik.com (just use the big search bar on the front page 😊) in case what you find doesn't match the blog post.

/Sonja

To help users find verified answers, please don't forget to use the "Accept as Solution" button on posts that helped you resolve your problem or question.

View solution in original post

QVUser2019
New Contributor

Re: QV Web Service / Server Performance

Thanks for the information Sonja, I will begin my investgation based on your recommendations.