Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

gencsoy
New Contributor III

QV10 Server NTFS - cache of local groups

Hello QlikCommunity,

we use QlikView 10R2 Server with IIS7. I use the NTFS access method (local groups with domain users within). We have more than 35 applications online. Some user could access to only 1 or 2 application. The problem is now, that if I get a new user or an existing user should access to a new application, I've to change this local groups and extend it which the username.

With QlikView 8.5 it takes only a few minutes and the user was able to access to the new application. Now with QlikView 10R2, the users have to wait more than half an hour or sometimes more than one hour.

In the QlikView Server reference manuel I've find out:

"...QlikView Server will cache group membership lookups for 15 minutes."

I've already disabled caching in IIS7 and tried different settings on QVDistributionService.exe.config and so on. Is there anywhere a possibility to change this setting of the QlikView Server? I do not want to say to our users: "Please wait until 15 minutes or 1 hour to get access to QlikView applications..." That's not QlikView like.

Best regards,

M.Gencsoy.

Tags (1)
4 Replies

QV10 Server NTFS - cache of local groups

Hi

After Giving proper access/Authorization to the document.

I would request you to restart qlikview server service once.

Then changes will take place Immediately.

Hope that helps

Regards

ASHFAQ

gencsoy
New Contributor III

QV10 Server NTFS - cache of local groups

That's not a solution. We've more than 200 users. If I restart then I would kick off every user.

Best regards,

M.Gencsoy.

danielrozental
Honored Contributor II

QV10 Server NTFS - cache of local groups

You should change the QlikView Directory Service config file, not the QlikView Distribution.

If you're using local groups then change

  <Local>

    <!-- How many minutes users and groups are cached before automatic refresh -->

    <add key="CacheExpiryInMinutes" value="15" />

  </Local>

gencsoy
New Contributor III

QV10 Server NTFS - cache of local groups

I tried this settings, I've set the cache to 1 minute, but it doesn't work.

But it's better now, it takes 15 minutes until half an hour not longer.

Community Browser