Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Not applicable

QVS will only load 1 document

Greetings All,

We are experiencing a condition where users started receiving the error message “Failed to open document, You don’t have access to this document.[19]”  The users DID have Doc CAL’s.

At first if the user retried they would be able to open the document.  Eventually retrying failed also, within about 20 min time.

So we restarted our servers, then only the first document we tried would open, all others would get the Failed to open document message.  We were at v11.2 SR6.

We reverted to an SR5 SNAP we took of our environment prior to applying SR6. Multiple documents were able to be opened again.  We did not reapply the SR6.

After about a week the failures reappeared.  Tried restarting the servers again, and again all was well for a period of time, then the failures would start again.

The product manager/owner believes that it has something to do with his having added more CALs to our pool of available CALs because it started occurring sometime after he added CALs.

Has anybody experienced anything like this?

Thanks for your time,

Bob

1 Solution

Accepted Solutions
Employee
Employee

Re: QVS will only load 1 document

Bob,

The only other thing that I can think that might be happening is that in the license LEF, it has

"NUMBER_OF_DOCUMENTS;0;; " which will prevent you to open any documents.

Gio

8 Replies
datanibbler
Esteemed Contributor

Re: QVS will only load 1 document

Hi,

I guess you have checked this already and/or it will not be applicable to your scenario, but - we have experienced that here and there, never en masse as in your case. The reason here was always that the user's password had expired due to company_policy and had not been changed, so "physical" network_access to the directory where we store all our QV_apps was not available anymore.

Employee
Employee

Re: QVS will only load 1 document

Bob,

What error does the end user sees when it starting to fail? Not what you see in the logs, but what error end-users sees in the process of opening the document. This is key because it could be, lack of CALs, Section Access or a true Qlik defect. 

Now when you say " After about a week the failures reappeared." this still in SR5 or SR6? if still persist in SR5, it seems not to be a version problem, but something that changes, either in Qlikview and/or environment.

gio

Not applicable

Re: QVS will only load 1 document

Below is the error the user sees.

Have not reapplied SR6.

Still SR5.

-Bob

Employee
Employee

Re: QVS will only load 1 document

Bob,

That looks more a Section access issue, does the document have section access?  if they do, when end user start seeing the issue can you try to removed all section access and try again and see if the issue persist, or try to open a document that has NO section access.

Gio

Not applicable

Re: QVS will only load 1 document

Giuseppe,

Very very few, 4 out of 80+ of our documents have section access.

Thanks anyway!

Bob

Not applicable

Re: QVS will only load 1 document

Hi,

Passwords are not the issue.  The snap we restore dose not include the document directory, just server platform.  Same users are able to open documents right after the snap is restored.

-Bob

Employee
Employee

Re: QVS will only load 1 document

Bob,

The only other thing that I can think that might be happening is that in the license LEF, it has

"NUMBER_OF_DOCUMENTS;0;; " which will prevent you to open any documents.

Gio

Not applicable

Re: QVS will only load 1 document

Qlik Tech just got back to me saying that they are using a new system to generate the LEF's.

Thanks All   !!!

Bob

Community Browser