Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Highlighted
Employee
Employee

QlikView Task running "forever" in 11SR1

Colleagues,

We´ve upgrated one of our production servers to 11SR1.

Our server is a Win2003R2 Standard Edition x64 with SP2 installed.

Since then, we are experiecing a weird issue: some tasks seems to be "running" into QEMC even though the task has aborted.

Our QDS log shows some lines like:

(2012-05-24 09:04:08) Information: Closed the QlikView Engine successfully. ProcessID=5592

(2012-05-24 09:04:08) Error: The task "Cargas/Gera QVD - Cronogramas.qvw" failed. Exception:

(2012-05-24 09:04:08) Error: QDSMain.Exceptions.DistributionFailedException: Distribute failed with errors to follow. ---> QDSMain.Exceptions.ReloadFailedException: Reload failed ---> System.Threading.ThreadAbortException: Thread was being aborted.

(2012-05-24 09:04:08) Error: at System.Threading.WaitHandle.WaitOneNative(SafeHandle waitableSafeHandle, UInt32 millisecondsTimeout, Boolean hasThreadAffinity, Boolean exitContext)

(2012-05-24 09:04:08) Error: at System.Threading.WaitHandle.InternalWaitOne(SafeHandle waitableSafeHandle, Int64 millisecondsTimeout, Boolean hasThreadAffinity, Boolean exitContext)

(2012-05-24 09:04:08) Error: at QDSMain.ReloadTask.Reload(String fileName, TaskResult taskResult, String sectionAccessUserName, String sectionAccessPassword, eReloadOptions reloadOption, String variableName, String variableValue, Boolean moniterCpuUsage)

(2012-05-24 09:04:08) Error: --- End of inner exception stack trace ---

(2012-05-24 09:04:08) Error: at QDSMain.ReloadTask.Reload(String fileName, TaskResult taskResult, String sectionAccessUserName, String sectionAccessPassword, eReloadOptions reloadOption, String variableName, String variableValue, Boolean moniterCpuUsage)

(2012-05-24 09:04:08) Error: at QDSMain.DistributeTask.Execute(TaskResult currentTaskResult)

(2012-05-24 09:04:08) Error: --- End of inner exception stack trace ---

(2012-05-24 09:04:08) Error: at QDSMain.DistributeTask.Execute(TaskResult currentTaskResult)

(2012-05-24 09:04:08) Error: at QDSMain.Task.AbstractTask.TaskExecution(ILogBucket logBucket, TaskResult taskResult)

(2012-05-24 09:04:08) Error: Task failed with exception

(2012-05-24 09:04:08) Error: Exception=The currently executing operation was aborted.

When this occur I have to restart the Distribution Service, but as the problem became more frequent I´ve downgraded to version 10SR4.

Any of you have an idea about what´s happening?

Best Regards

1 Solution

Accepted Solutions
Employee
Employee

Re: QlikView Task running "forever" in 11SR1

Hello ALL,

We´ve done a OS reinstall + QVS Fresh Install and problem seems to be solved.

3 days without "Highlander tasks"

14 Replies
MVP
MVP

QlikView Task running "forever" in 11SR1

Hi,

Some questions in regards to the installation and that issue:

  • Does the installation process run without issues or warning messages?
  • Does that happen to all tasks or only to some of them?
  • Do you have .NET 4 Extended installed as a role in your Server?
  • Does the user running the QDS have permissions or has it changed anyway?
  • Did you upgrade or did a fresh install?
  • Did you try renaming the C:\ProgramData\QlikTech folder and let the install process create a new one?
  • Does that keep running if you refresh the QMC webpage?

Hope that helps.

Miguel

Employee
Employee

Re: QlikView Task running "forever" in 11SR1

Does the installation process run without issues or warning messages?

Yes

Does that happen to all tasks or only to some of them?

Only some of them

Do you have .NET 4 Extended installed as a role in your Server?

No

Does the user running the QDS have permissions or has it changed anyway?

Same permissions of 10SR4

Did you upgrade or did a fresh install?

Upgraded first

Install renaming QlikTech folder

Did you try renaming the C:\ProgramData\QlikTech folder and let the

install process create a new one?

Yes

Does that keep running if you refresh the QMC webpage?

Yes, when I restart QDS they show as "failed"

Atenciosamente,

Cléver Anjos

QlikView Team

clever@swb.com.br

9992-8765 / 3291-6618

(Embedded image moved to file:

pic55169.gif)SWB

  • SWB Soluções Integradas Ltda | Av. Cesário Alvim, 2258 - CEP: 38400-696

- Uberlândia-MG Brasil - www.swb.com.br

As informações contidas neste e-mail e quaisquer documentos nele anexados

podem ser particulares e são propriedade confidencial da SWB Soluções

Integradas. Se você não for o destinatário ou se recebeu esta mensagem

irregularmente ou por erro, por favor, apague o e-mail e avise o

remetente o mais rápido possível. Este e-mail não pode ser divulgado,

armazenado, utilizado, publicado ou copiado por qualquer um que não o(s)

seu(s) destinatário(s).

From: Miguel Angel Baeyens <qliktech@sgaur.hosted.jivesoftware.com>

To: Clever Anjos <clever@swb.com.br>

Date: 04/06/2012 05:17

Subject: [Deployment and Management (Server/Publisher/AJAX/IE/Web

Parts)] - Re: QlikView Task running "forever" in 11SR1

MVP
MVP

QlikView Task running "forever" in 11SR1

Hi,

The only obvious reason I see from your answers is that QlikView 11 requires .NET 4 Extended in order to work properly, while some releases of QlikView 10 will work with .NET 3.5.1

Hope that helps.

Miguel

Employee
Employee

Re: QlikView Task running "forever" in 11SR1

Thank you Michael, I´ll check this

Atenciosamente,

Cléver Anjos

QlikView Team

clever@swb.com.br

9992-8765 / 3291-6618

(Embedded image moved to file:

pic17165.gif)SWB

  • SWB Soluções Integradas Ltda | Av. Cesário Alvim, 2258 - CEP: 38400-696

- Uberlândia-MG Brasil - www.swb.com.br

As informações contidas neste e-mail e quaisquer documentos nele anexados

podem ser particulares e são propriedade confidencial da SWB Soluções

Integradas. Se você não for o destinatário ou se recebeu esta mensagem

irregularmente ou por erro, por favor, apague o e-mail e avise o

remetente o mais rápido possível. Este e-mail não pode ser divulgado,

armazenado, utilizado, publicado ou copiado por qualquer um que não o(s)

seu(s) destinatário(s).

From: Miguel Angel Baeyens <qliktech@sgaur.hosted.jivesoftware.com>

To: Clever Anjos <clever@swb.com.br>

Date: 04/06/2012 09:54

Subject: [Deployment and Management (Server/Publisher/AJAX/IE/Web

Parts)] - Re: QlikView Task running "forever" in 11SR1

chris_johnson
Contributor II

Re: QlikView Task running "forever" in 11SR1

Hi,

Did you manage to solve this one? I'm having the same issue on a server where we have upgraded from 10SR3 to 11SR1 only we have installed .NET 4 Extended.

It's a little concerning as it means the extract task we have doesn't run and therefore none of the reports that work off that will update.

Regards,

Chris

MVP
MVP

Re: QlikView Task running "forever" in 11SR1

Hi,

I have been doing some testing by myself and I'm pretty sure this is at least a unexpected behavior. So you better open a support case sending an email to support@qlik.com with the most detail possible.

Hope that helps.

Miguel

Not applicable

Re: QlikView Task running "forever" in 11SR1

Hi,

      I am also having some what same issue.

      I am using QV 11 SR1 server/publisher.Windows server 2008 R2 standard edition and .NET 4 Extended installed.

I am having issue with some tasks on publisher.Task status remains in running state in task details tab but when I see it in task history tab its shows as success.

Actually, task has run successfully and data is updated in QVD but status remains running, I am not able to abort/stop it from running status.Everytime I am deleting the task and creating new task for the same because I am not able resolve the issue.

Any help/suggestion would be a great help.

Cheers,

Amay

chris_johnson
Contributor II

Re: QlikView Task running "forever" in 11SR1

You may well be right. I've stopped and restarted the QlikView Server, Distribution Service and Management Service for good measure and all seems to be ok at the moment.

Very strange.

Regards,

Chris

chris_johnson
Contributor II

Re: QlikView Task running "forever" in 11SR1

Hi Amay,

I was getting the same problem. The only suggestion I have at the moment is to restart the QlikView services and hopefully it should reset itself.

Regards,

Chris

Community Browser