Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Not applicable

Qlikview Distrubution Service startup failure

Suddenly my server started to have this issue.  Qlikview Distribution Service is unable to start.  I tried changing users, checking permission on folders but no change.  DSC, QMS, QVS, QVWS starts without problem, and at management console all of them are UP.   At the top of the managent console ther is a message in orange "ReloadEngine @ Qlikview is down"

Selección_008.png

  Las reload was successfull  at 3:15 AM,  then the service went down.   At that time there was no user (admin)  changes at the server.

RUnning  windows server 2008 x64  8GB ram

Qlikview 11

Attached are Distribution Service LOG files

Windows Error Message:

Startup failure. Read the log file and/or event log for determinating the cause of this problem. Note! The service must have sufficient permissions in Publisher Application Data Folder: "C:\ProgramData\QlikTech\DistributionService". Exception=System.NullReferenceException: Referencia a objeto no establecida como instancia de un objeto. en QDSMain.Workorder.LoadTasks() en QDSMain.Workorder.Populate() en QDSMain.MainClass.CheckAndInitializeEnviroment(ILogBucket logBucket, ClusterRegistration clusterReg) en QDSMain.MainClass.Run()

7 Replies
Not applicable

Qlikview Distrubution Service startup failure

Tried everything on the forum,  lodctr /r  didn't work for me.  

Highlighted
Partner
Partner

Qlikview Distrubution Service startup failure

Hi Goo25,

I am getting the same error using Windows 2008 SR2 and Qlikview 11.

I did not tied the lodctr /r because I still what to understand what the command actually does... did you found out anything about the issue in the mean while?

Thanks!

Cheers,

Not applicable

Re: Qlikview Distrubution Service startup failure

Uninstall, reinstall. Fast and easy.

El 27/03/2012 07:10, "Vasco Rodrigues" <

qliktech@sgaur.hosted.jivesoftware.com> escribió:

**

QlikCommunity <http://community.qlik.com/index.jspa> Re:

Qlikview Distrubution Service startup failure created by Vasco Rodrigues<http://community.qlik.com/people/vmrodrigues>in

Deployment and Management (Server/Publisher/AJAX/IE/Web Parts) - View

the full discussion <http://community.qlik.com/message/204643#204643>

Partner
Partner

Re: Qlikview Distrubution Service startup failure

Hi Goo25,

I am getting the same error using Windows 2008 SR2 and Qlikview 11.

I did not tied the lodctr /r because I still what to understand what the command actually does... did you found out anything about the issue in the mean while?

Thanks!

Cheers,

SunilChauhan
Esteemed Contributor

Qlikview Distrubution Service startup failure

did you tried below

  • Try stop all services and restarting them again.
  • Did you set administrator permissions (or privileges enough) so the distribution service can write in the folders where the files are going to be stored (the root folder and mounted folders in the QEMC, System, Setup, QlikView Server, folders)?
  • Can you reload manually if you get locally to the files?

hope thiss helps

Not applicable

Qlikview Distrubution Service startup failure

SInce there is NO ReloadEngine service available under windows services,  I was unable to debug that problem.  After a couple of days trying to fine tune my system and no answer from support (not even a "ok, we'll look for an aswer",  I reinstall, reconfigure everything back.

  One thing I could find was that this was due right after an automatic update ( 3 AM)  of windows 2008 server. 

I tried rolling back those updates, but with the same problem.

As I posted before,  uninstall, reboot,  delete  "C:\ProgramData\QlikTech\"   ( remember to backup "your" files )  and install QV to the last release.

Chris.

MVP & Luminary
MVP & Luminary

Re: Qlikview Distrubution Service startup failure

I am now having this problem with QV11.2 SR1, and even the clean install with the Program Data folder removed does not work.

I've also tried rolling back and trying with QV11.0 SR2.

Does anyone have any solutions?

Steve