Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Qlikview only opening in AJAX

Hi,

 

I have a number of dashboards that I would like to open from the Access point using the IE plugin, however, whenever I try to open them, they always open in AJAX. The default in the QMC is IE Plugin but when I select "View Details" on a dashboard in access point I don't have the option of IE plugin just, full browser

Kev

 

12 Replies
Highlighted

Hi,

 

The client can be also selected at a document level. Did you check for that document on "User documents" on the QMC and Availability tab what clients do they have selected?

Cheers!

Please, remember to mark the thread as solved once getting the correct answer
Highlighted
Digital Support
Digital Support

Kevin, I suspect the reason things are not working as you expect is you are not using Internet Explorer 11 web browser, this is a requirement for the IE Plugin client, as it needs the ActiveX engine, which only Internet Explorer has, Edge is not currently ActiveX enabled either, just FYI.  If you have been using IE browser, be sure you are on version 11, that is pretty much the only supported version at this point too.  This is the best shot at root cause at the moment, let me know if I am wrong, and we can try to come up with some other ideas here, but I wanted to confirm this first.

Cheers,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Partner
Partner

Thank you for your replies.

We're definitely on version 11 for IE

Kev

Highlighted
Digital Support
Digital Support

Kevin, the only other thing that it can be at this point is someone has unchecked the following setting in the QMC:

Availability.png

If this is unchecked, and you are using Publisher, be sure to change the setting on the Source Documents tab, otherwise your change in the User Documents will likely be overwritten on the next run of the distribution task...  Hopefully this solves things, as I cannot think of anything else it could be.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Partner
Partner

if you click on View details on the accesspoint, is PlugIn available?

If not it is not installed or allowed to start (security rules)

Regards

Highlighted
Digital Support
Digital Support

Martin, thanks for that reminder, that made me think of another article that might be of use:

Enable Protected Mode setting...

If this is checked in the IE settings for the security zone in which things are running, that is another possible issue.

You can confirm in the IE settings that the ActiveX add-on is there too if you have not done so, that is via Tools\Internet Options\Programs tab\Manage Add-ons button.  Look to see if the Qlikocx is there, and you may need to change the Show: dropdown option to all add-ons as well...

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Partner
Partner

No the option for Plugin isn't available, so it must be the security?

 

Highlighted
Digital Support
Digital Support

Kevin, yeah, if that is greyed out, has to be something environmental going on such that the Plugin is not actually active.  In addition to the Enable Protected Mode, the other thing you could try on a machine that is not work, is in the Security zones, change the zone for us to Trusted Sites zone, sometimes that will allow everything to work, just FYI, worth a shot if you can change it.

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.
Highlighted
Partner
Partner

the option isn't there so not even greyed out