Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Highlighted
Not applicable

Re: Qlikview ticketing for SSO is not working in Qlikview 11

I faced the same problem and even I set the QVWS to allow anonymous, it behaves the same.....

Not applicable

Re: Qlikview ticketing for SSO is not working in Qlikview 11

Hello All,

I am sorry for posting my question here but I am not getting any solution to my post.

http://community.qlik.com/thread/107676 but I did not receive any replies. It is very crucial for us to achieve and any kind of inputs would be great.

Please find below the technical approach for the same.

  • User will make request to local apache server https://localhost/qlikview
  • As this url is configured as secure resource at Shibboleth Service Provider, it will redirect the request to Shibboleth Identity Provider for authentication.
  • Identity Provider authenticates the user (configured in our Active directory)and sets header attribute in response and pass it to Service Provider sitting on apache.
  • Apache will redirect the user to qlikview through reverse proxy (configured in apache httpd.conf)
  • Qlikview will find the correct header and allow user to access the resource.

Below is the configuration I have made at my Qlikview server end.

  • I am changing the authentication type from NTLM to Header . As in my portal end I am using Header injection for authentication and not NTLM.
  • As of security wise I have tried both NTFS and DMS authorization but no luck.

Below are the changes I have done in my httpd.conf file in Apache

Now, when user logs into the portal and tries to access the qlikview server, user is not getting redirected to the Qlikview url.
I have also followed the official Qlikview SSO guide (formerly known  as “Qlikview 10 Accesspoint SSO.pdf”) but nothing seems to be working. If you can provide me guidance on how to configure Qlickview, what header params should be injected and anything I need to add at my active directory side would be of great help for me.

Not applicable

Re: Qlikview ticketing for SSO is not working in Qlikview 11

Hi Abhishek,

Is your problem solved, if so what was the issue and how did you resolved?

In my case I dont use Apache web server as well. I ahve simple java based web application running on tomcat and trying to connect to Qlikview(we have QVweb server  and QV server) and trying to do SSO authentication by setting QvCookie in Http Header.

Please reply, that would be great.