Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Not applicable

Reload Action Does Not Work In Access Point!

Dear Community,

Background:


I have QlikView 11 SR2 (x64) and QVS available. My document has a button-action to reload the QVW and it works fine in the Client version.

Problem:


Reload action doesn't work when triggered from Access Point.

The problem is not specific to a particular document but seems to exist for all my documents.

I have tried reloading from Access Point using Full Browser as well as IE Plug in but in vain.

I have also tried the same using QV 11 SR1 and it still does not work.

Technical Particulars:

QV 11 SR2

Version: 11.0.11440.0

Licensed: Yes

Browser: IE with QV Plugin for IE

Has anyone experienced something similar before?

Please find my QVW sample attached for reference.

Regards

-Khaled.

1 Solution

Accepted Solutions
richcalligan
New Contributor III

Re: Reload Action Does Not Work In Access Point!

With a little more research, I found an answer.

http://community.qlik.com/thread/64511

Although it still doesn't trigger for me.

2 Replies
richcalligan
New Contributor III

Re: Reload Action Does Not Work In Access Point!

I also have this problem. I have a Document Trigger OnPostReload to run a Macro. This Macro runs when I reload from the client, but not when I reload from the QMC (trying to schedule reloads to export a graph as an image).

The code is as follows:

public function ExportImage

    ActiveDocument.GetApplication.WaitForIdle

    ActiveDocument.GetSheetByID("SH_MAIN").Activate

    vFolder = "\\ws1\Sites\Corporate\qlikview\"

    fileName = "Temperature.png"

    set obj = ActiveDocument.GetSheetObject("CH_TEMP")

    ActiveDocument.GetApplication.WaitForIdle

    obj.ExportBitmapToFile vFolder & fileName

end function


I even tried removing the WaitForIdle commands and it still won't run unless I do it from the Client Application.

richcalligan
New Contributor III

Re: Reload Action Does Not Work In Access Point!

With a little more research, I found an answer.

http://community.qlik.com/thread/64511

Although it still doesn't trigger for me.

Community Browser