Qlik Community

QlikView Management

Discussion Board for collaboration on QlikView Management.

Announcements
QlikWorld, June 24-25, 2020. Free virtual event for DI and DA gurus. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

SSL in Qlikview 11 with QV Webserver

Hi,

we are trying to configure Qlikview 11 to use SSL (https) and we want it to use the Qlikview Webserver (not IIS). Unfortunately the Server Manual for v11 doesn't explain this as the one for v10, and it seems there are some differences.

Does someone know what I need to do? Or has a manual which describes this in an understandable way? 🙂

Thanks,

Martin

13 Replies
Highlighted
Not applicable

SSL in Qlikview 11 with QV Webserver

Done... the config.xml was just in another place than expected.

Highlighted
Partner
Partner

SSL in Qlikview 11 with QV Webserver

Would you mind putting steps here on "How-to", so this thread could be useful to others?

Thank you for your contribution.

Highlighted
Not applicable

SSL in Qlikview 11 with QV Webserver

Hi,

actually it works almost as described in the v10 Server Manual Chapter 39. Here is how we did it for our Windows Server 2008 R2:

- Create a certificate for the server (remember to insert all possible names for the server, including the servername, servername.domain.lan, a possible public domainname)

- Import the certificate in the management console

- Get the thumbnail for the certificate (shown in the details) and remove all spaces

- Download GUIDGEN.exe somewhere (e.g. http://www.microsoft.com/download/en/details.aspx?id=17252)

- Create any ID in Registry Format

- Bind to SSL using "netsh http add sslcert ipport=ipaddress_of_the_server:443 certhash=thumbnail_from_above appid={generated id from above}" (here we had to install KB981506 from Microsoft due to an upcoming error 1312)

- Open the config.xml for the Webserver in e.g. C:\ProgramData\QlikTech\WebServer and add the line "<Url>https://servername:443/</Url>" (of course without the quotes and servername replaced by your servername) as the first line after the line "<config>"

- Open the Management Console, Tab System, Area Setup, Tree Entry in Qlikview Web Servers, Sub-Tab General, change the port in the dedicated field to 443 and check "Use https".

That's it. 🙂

Cheers,

Martin

Highlighted

SSL in Qlikview 11 with QV Webserver

Thanks Em Vau these is good to know, so you shoud mark your post as solved or something like that, Rakesh Mehta you should say thanks to Em Vau 

Regards both of you!!!

Highlighted
Partner
Partner

SSL in Qlikview 11 with QV Webserver

Thanks Em Vau. I knew it will help out someone lost going in the same directions.

@Moderators, please mark this one as correct answer.

Highlighted
Not applicable

Re: SSL in Qlikview 11 with QV Webserver

Hi EM,

I am having trouble with this process, we do not have a CA so how did you generate the certificate? I have tried using Open SSL but with no success.

Thanks,

James.

Highlighted
Not applicable

Re: SSL in Qlikview 11 with QV Webserver

Hi James,

I don't remember the exact way (did it with our admin) but he gave me a link to check:

http://www.robbagby.com/iis/self-signed-certificates-on-iis-7-the-easy-way-and-the-most-effective-wa...

Cheers,

Martin

Highlighted
Partner
Partner

Re: SSL in Qlikview 11 with QV Webserver

Hi,

I came across this post which I have yet to try out myself, but I hope it can help you.

http://community.qlik.com/thread/47704

David

Highlighted
Contributor
Contributor

Re: SSL in Qlikview 11 with QV Webserver

Dear all,

We are using Windows Server 2008 R2 and QlikView 11.2.

When we tried to bind to SSL, following error occurred:

*********************************************************************************************************************

C:\Users\Administrator>netsh http add sslcert ipport=0.0.0.0:443 certhash=dfec56

1ba9b166a6e2217fddeb6945da56b1ba8d appid={B38E087C-3463-4c86-BD7F-D2E5222F9468}

SSL Certificate add failed, Error: 1312

A specified logon session does not exist. It may already have been terminated.

*********************************************************************************************************************

We tried to install Windows fix KB981506 from Microsoft, but it said "The update is not applicable to your computer".

Any suggestion on this?

Regards,

Johnny